2

Got this message when starting a Windows 2000 VM on VMware Fusion 6 on a Retina MacBook Pro with OS X Mavericks:

This virtual machine's policies are too old to be run by this version of VMware Fusion.

Could only find this Danish question with no answers.

Fusion 6 is supposed to

Edit: extra information about the settings, .vmx and .vmxf files.

Opening the settings for this VM gets the same message.

VMware Virtual Hardware version overview.

There are a few lines with the word policy in the .vmx file, but none in the .vmfx file. And there is a .vmpl file (which seems to have to do with the -now discontinued- VMware ACE that used to ship with older VMware versions including VMware 6.5).

These are the lines with policy in the .vmx file:

tools.upgrade.policy = "upgradeAtPowerCycle"

policy.vm.mvmtid = "52 3f 1e 13 9d 44 69 76-7c dd cc d1 67 a4 46 32"
policy.vm.managedVMTemplate = "FALSE"
policy.vm.managedVM = "FALSE"

Note:

This is not a VMware Fusion specific question, searching for "This virtual machine's policies are too old to be run by this version of VMware" (so without Fusion or Workstation) reveals some nice links including Starting a virtual machine in Workstation or Fusion fails with the error: This virtual machine's policies are too old to be run by this version of VMware (2034362) which also answers this question.

2
  1. Open the virtual machine's configuration file .vmx using a text editor.

  2. Remove the lines which starts with policy.vm.*:

    policy.vm.mvmtid = "52 d6 6f f9 f3 36 0f 9f-31 da 9f f5 90 7b ce 76"
    policy.vm.managedVMTemplate = "TRUE"
    policy.vm.managedVM = "FALSE"
    
  3. Save the file and close the text editor.

  4. Restart the VM.


If you still encounter the error…

  1. Rename/delete the file with the extension .vmpl
  2. Restart the VM.

For further reading, check out this thread: VM's policies are too old to be run by this version

  • That's the thing: if I go to settings, I get the same message about policies. – Jeroen Wiert Pluimers Jan 19 '14 at 19:42
  • 1
    Ok - then try remove the three police.x lines from the .vmx file - also see this thread: communities.vmware.com/message/2099362 – Rene Larsen Jan 19 '14 at 20:50
  • Can you reword your answer by including the .vmx changes mentioned in your comment? Then I'll do some comment cleanup. – Jeroen Wiert Pluimers Jan 19 '14 at 23:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .