2

I have updated my Mac OS from Snow Leapord to Mevericks recently. I work behind proxy and I have set proxy for network and saved creadentials in Keychain too.

Still I get annoying system prompts for logging into proxy too many times.

Any solution to get rid of the Proxy login Popups ?

EDIT

I did following steps

  1. deleted proxy credentials from keychain List item
  2. removed the same from Proxy Settings
  3. Added proxy settings again ( without credentials )
  4. tried to access google from safari it prompts for crdentials ( twice - maybe for http and https connections as I am adding proxy for both ) -- After above prompts I can see my credentials saved in kechain as well for proxy
  5. Still can not access google from safari, can access same from Firefox / chrome ( they have seperate prompt for login ), even can access itune store from iTunes. (iTunes asked me for keychain access of proxy )
  6. removed https proxy and kept only http, now I can not Access iTune Store so added the same again

Here are my keychain attributes for proxy

Name : 127.0.1.1 (vishal.kardode)

Kind : Internet Password

Account : vishal.kardode

Where : http:// 127.0.1.1:80 ( for https proxy its https://... )

Comments : default

Added space between "http://" and "127.0.." as it was not allowing to post

EDIT2

The Issue Persists, now I can not conect to iTunes Store either ( using iTunes ) every time I open Safari or iTunes I get the prompt, every time keychain gets updated as I login using the prompt but not able to connect to https://google.com or iTunes Store. Surprisingly I can connect to other https site Here is screenshot of the proxy authentication prompt

proxy prompt

I have changed the ip of proxy server in above post to 127.0... . Actual ip starts with 172...

2

Quick question first, are you setting the proxies manually or are you getting the settings via Auto Discovery or an Automatic Proxy Configuration (APC) URL?

If you are setting them manually then you should be able to select Proxy Server requires password and enter the correct credentials there.

Proxies pane in Network/Advanced

If you are getting them as an APC URL then you may have a problem with that particular keychain. Using the Keychain Access utility look in both your login and iCloud keychains and delete any you find for the the proxy server.

Now you should be able to save your credentials properly.

  • I am setting my proxy manually as you have in screenshot only that I have proxies for both http and https – Vishal Kardode Jan 17 '14 at 8:53
  • 1
    Then why aren't you entering your credentials into there? That should work fine? Have you tried it to see what happens. – Tony Williams Jan 17 '14 at 9:04
  • Yes I have already entered creadentials there itself. Still I get those pop ups.. most of the time when I try to open Apple Applications like safari, itunes – Vishal Kardode Jan 17 '14 at 10:52
  • Have you checked that the server field only contains the one line as in this Q & A - apple.stackexchange.com/questions/27097/… Have you also tried deleting the keychain and allowing it to recreate? – Tony Williams Jan 17 '14 at 11:06
  • Kindly see my edit – Vishal Kardode Jan 17 '14 at 12:07
1

Copy the two proxy entries from your "log in" key chain into tHe "system" key chain and listo. That worked for me, an issues that drove me nuts over this past year.

0

OK, now you are starting to add some details lets get down to some decent testing.

Delete the keychains again.

Go into the Network settings and make sure that you have just the required text in both server fields for Web Proxy and Secure Web Proxy. Absolutely make sure by emptying the field and retyping the server name. Tick Proxy Server requires password and enter your login and password.

Reboot the computer.

Now try accessing two different websites, one that uses https and one that doesn't.

If you get prompted for your credentials provide them. Now go and check to see if a keychain item has been created for the proxy server.

It would also be good to know what your IP address is and why your work is using 127.* addresses

  • The Issue persists, kindly see my edit – Vishal Kardode Jan 20 '14 at 5:17
  • There is another Mac running "Mountain Lion" with same issue, I guess something with proxy server which did worked with "snow leopard". Anyways, appreciate your efforts. – Vishal Kardode Jan 20 '14 at 5:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .