I have a Time Capsule 802.11n 1 TB at work with some free space on it, and I decided to make a second backup on it, using Time Machine. I have about 358 GB used on the hard drive, and 25 GB of that are in a folder that I excluded from the Time Machine Backup, so the actual amount of data to be backed up is about 333 GB. Yet my initial backup (before any incrementals) took up 477 GB of space on the Time Capsule. Even after running hdiutil compact on the sparse bundle, I was only able to reduce its size to 455 GB. Isn't that still excessive? I understand there may be some overhead, but really, isn't ~40% overhead excessive?

A piece of information that may be relevant to the question: Unfortunately my rMBP has no Ethernet and I haven't purchased the USB-to-Ethernet adapter either, so the backup proceeded very slowly under 802.11n. Unable to finish the backup in a single day, I took the rMBP home each night, and on the following day, I would let Time Machine resume the backup (it did seem to be resuming since the amount to be backed up decreased every day). Eventually, a week after starting the backup, I finished it for the first time, but with a size of 477 GB as mentioned above.

Edit: here's the output of sudo tmutil listbackups | tr '\n' '\0' | xargs -0 sudo tmutil uniquesize, showing backup dates and their uniquesizes:

16.6G    /Volumes/Time Machine Backups/Backups.backupdb/MacBook Pro/2014-01-15-182027
3.4G     /Volumes/Time Machine Backups/Backups.backupdb/MacBook Pro/2014-01-22-161530
623.1M   /Volumes/Time Machine Backups/Backups.backupdb/MacBook Pro/2014-01-23-160536
1.0G     /Volumes/Time Machine Backups/Backups.backupdb/MacBook Pro/2014-01-23-171738
1.1G     /Volumes/Time Machine Backups/Backups.backupdb/MacBook Pro/2014-01-23-182535
4.7G     /Volumes/Time Machine Backups/Backups.backupdb/MacBook Pro/2014-01-24-144806

This is, of course, a few days after the question was asked, so there are new backups. But notice that there is only one backup made before the question was asked.

  • Does tmutil listbackups show more than one backup? (Assuming it works with Capsules—I've only used TM with local drives.)
    – Mattie
    Commented Jan 23, 2014 at 20:38
  • My Mac (running 10.8... I don't see what version you are running?) shows a figure for "Estimated size of full backup" when I press the Options button in System Preferences > Time Machine. What is your figure there?
    – Ashley
    Commented Jan 27, 2014 at 23:50
  • Side note - Get a thunderbolt ethernet adapter as opposed to a USB one. The USB adapters can only handle 100mbps ethernet. Thunderbolt does full gigabit.
    – Chris A
    Commented Jan 31, 2014 at 0:25
  • Are you using Parallels or other sort of virtual machine?
    – Andrew U.
    Commented Jan 31, 2014 at 13:22

4 Answers 4

  1. See if there are files marked inprogress on the machine's backup folder

TimeMachineDisk -> Backup.db -> MachineName.

You can try to remove them with tmutil. Do not remove them with finder.

  1. You can get enormous files if the source disk has has certain classes of file system errors. Boot off of your recovery partition or off a DVD and run diskutil repair disk. Then us tmutil to remove the monster backup and try again.

  2. Check out Pondini's page about Time Machine. http://pondini.org/TM/Home.html This is an excellent information and troubleshooting guide.

Thanks, BTW for the headsup that an rMBP has no ethernet jack. This makes it a non-starter for me.

  • I'll look for inprogress files when I'm at work again. BTW, although there's no built-in Ethernet jack, there is a Thunderbolt to Gigabit Ethernet Adapter, which won't take up an USB slot since it's Thunderbolt, and it's not too expensive ($29): store.apple.com/us/product/MD463ZM/A/…
    – swineone
    Commented Jan 24, 2014 at 12:46
  • I just looked and there are no files with inprogress anywhere in their names. So that's not it either.
    – swineone
    Commented Jan 27, 2014 at 13:29

On mobile Mac's, Apple has enabled a function called Local Snapshots in their modern versions of OS X (Lion and later).

They basically function as incremental backups along the way of things that have changed. I have a feeling that these have been building up on your machine and thus the first backup will not only be the backup of the data but also these snapshots.

If you go into the Time Machine mode and look through the backups, if there are entries which are not purple (they are grey or white) then those are Local Snapshots included.

You can disable them by executing the following in a Terminal Window

sudo tmutil disablelocal

It will prompt you to enter your admin password.

Full details about this can be found on Pondini's Time Machine article #30

  • One of the first things I did when I got this new computer was disable local snapshots as they were taking too much space. Sorry, I don't think that's it.
    – swineone
    Commented Jan 24, 2014 at 17:30

I had the same problem recently. One tool that helped immensely in discovering why my backups were so large was Backup Loupe. Highly recommended.


Just to give this question some closure, I got a Thunderbolt to Ethernet adapter, deleted the old backup -- and excuse my digression, but this something I won't recommend to anyone because it is SO SLOW; please, just erase the full drive from Airport Utility if at all possible, which wasn't my case -- and made a new one, connected via Ethernet, without any interruption. As a result, I got a .sparsebundle of the right size and ended up saving over 100 GB on my Time Capsule. But thanks anyway to everyone for their answers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .