I have downloaded the Flash 12 updater and tried to run the update. The updater complains that I need to close cfprefsd.

When I force quit cfprefsd though the Activity Monitor, it restarts it's self. I tried shutting down all my applications that were running, but this also caused cfprefsd to restart after force quit via Activity Monitor.

I have googled this with out many helpful results.

Any suggestions?

Software OS X 10.9.1 (13B3116)


There are actually two cfprefsd processes running. One is the daemon owned by root and the agent owned by the logged in user.

If you kill both then the agent will respawn, notice the missing daemon and get it respawned.

If you just kill the daemon it takes a while to respawn so you should be able to run the updater.

At the command line :-

ps ax | grep cfprefsd

which will list the two processes with the process ID in the left column -

7308   ??  S      0:00.05 /usr/sbin/cfprefsd agent
7365   ??  Ss     0:00.02 /usr/sbin/cfprefsd daemon

so then

sudo kill -9 7365 and enter your password when prompted.

or whatever the PID is and quickly run the updater.

Why Adobe thinks it needs to have this process out of the way is a question for another day but Adobe updaters are known for their quirks.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .