10

I am a German User, but i am using a US Keyboard and the US Extended Keyboard Layout. Sometimes I need to use German Umlauts, and I usually rely on the "press and hold for accented characters" feature of OS X.

However, this is not always available. I cant seem to find a pattern in this behavior. Sometimes I log in, and it works flawlessly, sometimes it doesn't work at all and just repeats the character I press for a long time.

I switched to different keyboard layouts (US, US Extended, US International PC) and different "Preferred Languages" in the "Language and Region" settings.

I also tried the defaults write -g ApplePressAndHoldEnabled -bool true setting, but also no luck.

I have the same problem on different Macs; at work and at home.

How do I configure this feature correctly?

  • Does the behaviour change between restarts when using the same application? Does it always work in TextEdit? – Graham Miln Jan 16 '14 at 10:35
  • No, even restarting of apps does not help. Once this feature fails, it fails for all the apps, even TextEdit and my browsers. – DaveSliwo Jan 16 '14 at 13:09
  • While this is not a solution to your problem, it might be a reasonable workaround. In the US Extended layout, you can also get umlauts with pressing option-u before the vowel, as well as other accents via option-a, option-e. A possibly complete list is here: symbolcodes.tlt.psu.edu/accents/codemacext.html – Kent Jan 19 '14 at 5:58
  • Do you always have another keyboard layout like German, French, or Spanish on your active list? I have seen reports in another forum that adding this helped some users with similar problems. – Tom Gewecke Mar 5 '14 at 0:04
  • I can report that the problem of press and hold giving accented alternatives/not doing so at random is present for me, on OS 10.9.2 (installed on a newly formatted disk). – user1256923 Mar 7 '14 at 13:56
5

When it stops working, does ps -ef|grep PressAndHold include a line for /System/Library/Input Methods/PressAndHold.app/Contents/MacOS/PressAndHold? If it doesn't, try to run open -a PressAndHold. Or if it does, killall PressAndHold;open -a PressAndHold might also be worth a shot.

You could also try to delete ~/Library/Preferences/com.apple.HIToolbox.plist. Normally defaults read com.apple.HIToolbox should show com.apple.PressAndHold under AppleEnabledInputSources and AppleSelectedInputSources.

  • 1
    Stopped working randomly, PressAndHold was present in my ps listing, had to killall PressAndHold;open -a PressAndHold to get it back. Thanks! – Greg Olsen Jun 1 '15 at 16:24
4

The option/alt + key combinations should be more reliable once you learn them. For example alt + s types ß and alt + u followed by a vowel types the umlauted vowel äëïöü.

P.S. Thanks for pointing out the press and hold technique that's pretty interesting.

1

This worked for me. The press and hold had stopped working in all programs. I followed the instructions below and it worked again

A way to make sure it is enabled is: open Terminal, from Applications, Utilities, then in the Terminal window type, exactly,

defaults write -g ApplePressAndHoldEnabled -bool true

press Enter and finally quit Terminal

The key should now do the accents.

  • This worked for me in addition to the open -a PressAndHold command. Not sure why it had been voted down. – Richard Wеrеzaк May 24 '16 at 7:38
  • For some reason, I had to remove the -g flag in order to get it working on Mojave. defaults write ApplePressAndHoldEnabled -bool true – fedesismo Jul 11 at 14:03
0

A few things: I'm on OS 10.9.2 and press and hold is not working for me at the moment. If I type:

defaults read -g

I get:

{
AppleAntiAliasingThreshold = 4;
AppleAquaColorVariant = 6;
AppleEnableMenuBarTransparency = 0;
AppleLanguages =     (
    en,
    fi,
    fr,
    de,
    "zh-Hans",
    "zh-Hant",
    ja,
    es,
    it,
    nl,
    ko,
    pt,
    "pt-PT",
    da,
    nb,
    sv,
    ru,
    pl,
    tr,
    ar,
    th,
    cs,
    hu,
    ca,
    hr,
    el,
    he,
    ro,
    sk,
    uk,
    id,
    ms,
    vi
);
AppleLocale = "en_GB";
AppleMiniaturizeOnDoubleClick = 0;
AppleUserLanguages = 1;
InitialKeyRepeat = 68;
KeyRepeat = 6;
NSAutomaticDashSubstitutionEnabled = 1;
NSAutomaticQuoteSubstitutionEnabled = 1;
NSAutomaticSpellingCorrectionEnabled = 1;
NSNavPanelFileLastListModeForOpenModeKey = 1;
NSNavPanelFileLastListModeForSaveModeKey = 1;
NSNavPanelFileListModeForOpenMode2 = 1;
NSNavPanelFileListModeForSaveMode2 = 1;
NSNavPanelSidebarKeyForOpen =     (
);
NSNavPanelSidebarKeyForSave =     (
);
NSNavRecentPlaces =     (
    "~/Fede/Work/Parkinson/EPIC4PD/H2020",
    "~/Desktop/Archival",
    "~/Fede/Work/QTL/Rana-temporaria/Fede-new",
    "~/Fede/Cloud",
    "~/Fede/Cloud/OneDrive"
);
NSPreferredWebServices =     {
    NSWebServicesProviderWebSearch =         {
        NSDefaultDisplayName = Google;
        NSProviderIdentifier = "com.google.www";
    };
};
NSTableViewDefaultSizeMode = 1;
NSUserDictionaryReplacementItems =     (
);
NavPanelFileListModeForOpenMode = 1;
NavPanelFileListModeForSaveMode = 1;
WebAutomaticSpellingCorrectionEnabled = 1;
"com.apple.keyboard.fnState" = 1;
"com.apple.springing.delay" = "0.5";
"com.apple.springing.enabled" = 1;

}

i.e I am not getting ApplePressAndHoldEnabled in the first place. in ~/Library/Preferences/com.apple.HIToolbox.plist I have the correct instances of com.apple.PressAndHold, but I noticed a file /Library/Preferences/com.apple.HIToolbox.plist which does not have com.apple.PressAndHold. One guess is that if com.apple.PressAndHold were to be added there press and hold might work...

0

For me, it didn't work until I restart the application, which was Pages, in my case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .