1

I have a rather strange problem with my MacBook Pro (13-inch, Late 2011). Whenever I start my computer I see a flashing folder with a question mark. I know this is supposed to be a common problem wich can be usually solved by the solution provided by Apple support.

However, my issue is different. Here is how it all started: I wanted to install Windows using bootcamp. The installer complained that my hard disk was corrupted and that I need to repair it using the recorvery HD. When I tried, I was asked to provide the firmware password. Since I did not have it ( I wrote it it on a piece of paper that I did not have access to at the moment), I went back and restarted my in target mode so I can back up my documents on another mac. Unfortunatelly, after restarting in target mode, I was asked to provide the firmare password again. When I finally got the password, my computer restarted with a flashing folder with a question mark.

I have tried all troubleshooting available on the internet and nothing seems to work. Some people think that I need to replace my internal HD cable. However, how can this be? I didn't mess up with my hard disk at all. During the troubleshooting, I used a bootable hard-drive, and notice that I could no longer see my HD in the list of available hard-drives. It is like it is completely gone. Can someone please suggest any solution? Please keep in mind that I live thousands of miles away from any Apple store. I can't get any official support. I have to fix this myself.

  • Start your macbook with the alt key pressed, choose your mac disk and it should boot. It looks like your Windows tries to start up without boot partition resulting in that error, I've had the same. Select the right disk when the alt-key is pressed on power up. – Rob Jan 16 '14 at 10:39
4

It would seem that the drive is no longer "blessed".

First, try booting the Mac while holding down the option key and if the drive is in the list of boot devices then selecting it once will "bless" the drive and you should be able to boot off it once again.

If that doesn't work then boot off the bootable hard drive you mentioned and run Disk Utility which can be found in /Applications/Utilities and you should be able to see the drive in the drive list. Once there you can try to first verify then repair the disk.

  • Thanks for your comment. I will try this and let you know how it goes – Dillion Ecmark Jan 17 '14 at 6:26
0

This has happened to me (iMac Early 2008) and it was a hard drive failure. You should try what Tony said, and if that doesn't work, you should go to the Genius Bar. When this happened to me, the drive was 6 months old and wouldn't spin up (meaning it failed one of its self-tests and shut down). Hopefully, if this is a hard drive failure, they can recover your data. You should also try Apple Hardware Test. You can follow the steps here to use Apple Hardware Test: http://support.apple.com/kb/HT1509?viewlocale=en_US&locale=en_US

0

Booting into recovery mode is my first inclination. If/when that doesn't work, use another mac with the same 10.X and a SATA adapter to reinstall OSX on to the partition that you use for OSX.

I think your problem stemmed from corruptions on your disk, then you partitioned it without fixing them. Booting into the bootcamp setup mode is... a delicate process is the best way to put it. Provided you do it perfectly there isn't any problems, but deviate or have any issues going into it and it can mess up your EFI_BOOT settings.

Reinstalling OSX on the partition should just fix the OSX files on the drive, not touching any of yours. Also run Disk Utility to fix/verify everything.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .