1

I'm suddenly having a very strange problem on Mavericks.

When copying large files around my system, between local disks or to and from my NAS server, I randomly get a failure stating "The file ... could not be copied because it is in use."

The problem is that this error message appears after the data has actually copied. Suppose I copy a 1GB file. The progress bar moves, network activity occurs (if transferring to the NAS), and so on... The error appears as soon as the file copy should finish.

A reboot does not solve this. This is becoming almost reliably reproducible as well. I have no unusual system extensions installed and this behavior started to appear suddenly and seems to have progressively worsened. Initially when it occurred a second copy often would work, but now a second or even third copy often fails and it takes sometimes upwards of four copies to make it work.

I can successfully copy anything at the terminal using cp, but this isn't really a solution - this is such a simple operation and there is no reason it should be causing errors like this.

As i said, the most interesting part is that it is occurring after the data has actually been moved. When the copy fails, it then deletes the corresponding destination file.

It's worth pointing out that this does not occur if copying to the same drive. For example, hitting ⌘ Cmd+D to duplicate a file and make a copy on the same disk never fails. Even moving around the same disk works as it should.

(No, I'm not trying to move, but rather simply copy a file.)

Anyone seen this before?

  • This problem has gotten better, but not completely solved. Now, if I back out of the folder I intend to copy to and drop the files onto the folder, then copies and moves always succeed. It seems to be a race condition with Quick Look and the file copy process. I've bug reported it to Apple (again) so hopefully they will continue to work this out. At least I have a partially workable, albeit non-elegant, solution. – fdmillion Jun 27 '14 at 0:25
1

Mavericks uses SMB2 as default, which still is a little bit buggy and might be causing this problem. You can force Mavericks to use SMB again by entering this in Terminal:

echo "[default]" >> ~/Library/Preferences/nsmb.conf; echo "smb_neg=smb1_only" >> ~/Library/Preferences/nsmb.conf

and restore SMB2 default by:

rm ~/Library/Preferences/nsmb.conf

Source: http://hints.macworld.com/article.php?story=20131122083837447

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .