31

I have OS X Mavericks with the Server software installed. The server machine is an iMac with a Drobo attached via USB. I use the Server Time Machine service to create a backup server on the network, using the Drobo as the storage device for backups.

I am currently backing-up two Macbooks to this Time Machine Server. Some backups will succeed but every other day or so, I will get an error on both laptops that the backup failed with the following reason: The backup on Server is already in use.

I have only been able to clear this problem by restarting the server.

Does anyone know why this might be occurring and what I might be able to do in order to prevent it from happening?

Thank you.

44

Just for the completeness of this issue. If you land here and do not use MacOS Server, but a Synology DiskStation, do the following:

  • Login to your DiskStation as root
  • Open the main menu
  • start the resource monitor
  • switch to connected users
  • select the blocked user and press disconnect
  • 3
    I didn't find the above answer until after I fixed the problem, but on Synology DSM 5.1, I found that disabling and re-enabling the AFP service also makes the error go away. – Scott Dudley Apr 1 '15 at 12:17
  • I used this solution on a Synology DSM 5.1 - Thanks mana! – callisto Apr 14 '15 at 10:41
  • The above answer didn't fix my problem, the only connected user it showed was me logged in to the admin page. However, @ScottDudley's suggestion worked great, thanks Scott! – blm Mar 26 '16 at 18:29
  • @ScottDudley Same here, just needed to check/uncheck AFP service. No need to do the above as root. – Winterflags Nov 30 '16 at 19:27
  • So basically this also means: restart netatalkd if you're running any other NAS based on this. Helped with pure netatalk, too. – Theuni Apr 16 '17 at 9:33
8

I have got this problem since I got my OS X Server, and still do get this error. Whenever my router disconnects, it causes this until I fix it. However, instead of restarting the server, there's a workaround:

  1. Open Server.app (I do this on the client that I'm using, but you could do it on the server itself) and login.
  2. Select the File Sharing service.
  3. Go to the Connected Users tab.
  4. Select each connected user and click Disconnect.

I have to do this so often I wrote a Keyboard Maestro macro for this, but any scripting software would do this.

  • 2
    If that works have you tried just bouncing the AFP process with sudo launchctl stop com.apple.AppleFileServer followed by sudo launchctl start com.apple.AppleFileServer ? – Tony Williams Jan 15 '14 at 23:12
  • Thanks for the suggestions. Disconnecting users does allow me to recover from the error, but doesn't prevent the problem from occurring again. My goal is to stop the error from occurring. @TonyWilliams I'd rather not restart the apple file server as I'm concerned it might interrupt other backups in progress. – Swisher Sweet Jan 16 '14 at 1:19
  • That wasn't so much a "solution" as a possible diagnosis step :) – Tony Williams Jan 16 '14 at 3:19
  • killall AppleFileServer does recover. I do this myself. Unfortunately I have not found a way to prevent the problem. – Alan Shutko Jan 16 '14 at 3:29
1

If disconnecting users "fixes" the problem then it's almost certainly somewhere in the AppleFileServer process.

Have a look at the AFP access and error logs and see if you can find a better error message than the one you get on the client Mac and you may well be closer to a solution. Click on Logs in the left hand pane of the Server app and then select AFP Error in the pop up below the log window.

The problem might also be with the RAID in the Drobo. Have you tried another hard drive just to see if the problem goes away? Which model Drobo is it? Drobo support mutters under its breath about Lion and Time Machine so may well also have problems with Mavericks and Time Machine. (I get around the problem by having a single 2TB drive with 3 partitions as my TM target and then back that up to my Drobo using Carbon Copy Cloner.)

1

@grgarside is on the money - this happens when there are two connections to the backup from the same IP.

On my network I stopped it from happening by disabling guest access to the backup drive(s).

On the server machine,

  • Login to OS X Server
  • click File Sharing
  • click on the settings tab
  • select the backup drive in question
  • uncheck the box Enable Guest Access
  • click the connections tab
  • then disconnect all users.

Login to the server on the client machine again and you're good to go. Once guest access was disabled, the client won't automatically connect to the server using the guest protocol, thus preventing multiple connections.

0

I had a similar issue with my Synology NAS after having followed Synology's Time Machine guide. When trying to connect to the Backup Disk, Time Machine said "You do not have the necessary read, write and append privileges on the selected network backup disk."

The only solution that worked for me was to restart Synology DSM by clicking on the person/user icon in the top right and selecting "Restart"

0

If you get the error message "Time Machine could not complete the backup. The backup disk image “/Volumes/mac-backups-1/machine-name.sparsebundle” is already in use." and you are using a Synology DiskStation DSM 5.2 (NAS) as the destination for Time Machine backups, the following steps resolved the issue:

  1. Login to your DiskStation as admin
  2. Select the Options icon (at the top right -- looks like a person's head)
  3. Options > Account > Account Activity > Connected Users
  4. For each user on AFP Service and Resource: mac-backups, press disconnect (red circle with white horizontal bar). The issues seems to be that there are two or more connected users both connected to AFP > Resource: mac-backups. There should only be one.
  5. Click Refresh. There should now only be one user connected to AFP > Resource: mac-backups.
  6. On your MacBook > Time Machine icon > Start Backup. Time Machine backup begins (circling counterclockwise) and you no longer get the above error message.

I am not sure exactly how this situation occurs, but here is my theory: After disconnecting the MacBook and reconnecting to another network (moving my MacBook to another location while traveling), the connection to the synology resource: mac-backups (used by Time Machine) did not get properly disconnected, so when the machine was reintroduced into the network, another new connection was established, even though the existing connection was still present, creating a conflict and the subject error message.

To Be Tested: To prevent this error from happening again, if Time Machine is in-progress doing a backup, try doing a "Stop Backing Up" command in Time Machine before moving your MacBook to another location off-network. Hopefully, when you bring the machine back to the network where the synology NAS is located, the error should no longer occur.

-1

What worked for me was to reboot the DS, delete and recreate the Time Machine share.

From this post on Synology Forum https://forum.synology.com/enu/viewtopic.php?f=159&t=86535&start=15#p512709

  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Jan 2 '18 at 23:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .