2

I had to work out of the office today and brought a copy of the Windows 2000 appliance I have on my Windows 7 machine at the office.

Copied this to the Mac I am now on (Mavericks) and copied the files into the /Users/myUserName/VirtualBox VMs directory.

Added the host-only adapter to the VB preferences and then added this to the network for the specific machine.

When running the virtual machine I boots and then fails with

Failed to open a session for the virtual machine Win2000ServerAdv.

Nonexistent host networking interface, name 'VirtualBox Host-Only Ethernet Adapter' (VERR_INTERNAL_ERROR).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Now I am no netowkring expert but my guess is that issue lies with the fact that 'VirtualBox Host-Only Ethernet Adapter'is the name of the adapter on Windows and on a Mac this gets named to 'vboxnet0'.

Is there a simple work around for this poosibly, I thought there would have been a way to rename the vboxnet0 adapter name to 'VirtualBox Host-Only Ethernet Adapter' but cannot see anything for this, not even in the command line tools.

Any help in this regard would be great, or a simply 'No it cant be done' would be helpful.

Ta John

  • VirtualBox Host-Only Ethernet Adapter <- this is a second adapter setting that was turned on where your virtual box appliance originally was. It can be fixed. I'm not at my computer right now or I could answer this for you. Sorry. :-( – Danijel-James W Jan 14 '14 at 13:58
1

From https://www.virtualbox.org/ticket/7067:

On Linux I had to manually create the vboxnet0 interface:

$ vboxmanage hostonlyif create then manually edit each .vbox file and change all lines:

<HostOnlyInterface name="VirtualBox Host-Only Ethernet Adapter"/>

to

<HostOnlyInterface name="vboxnet0"/>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .