When I'm using the directions in the Maps application in Mavericks the distance is in miles instead of in km.

The "Measurement units" i set to "Metric" under "Advanced..." in Language & Region preferences.

I have toggled the setting multiple times and tried both relogging and rebooting to no avail.

Is there another way to change the unit to km instead of miles?

5 Answers 5


If you want to change the system to use metric units, you have to select a region (locale), which uses only metric units. Apple is not very good when it comes to internationalization. Especially the many small nationalities suffer from this attitude. It feels like American culture is walking all over you.

Go to System Preferences / Language & Region / Select a region which definitely uses the metric system. Maps should finally work.


I have by default distance shown as km https://cloudup.com/c9G7dDrWYOP and if I switch measurement units to US it distance is shown in miles https://cloudup.com/ceeeUdZFz2M

Don't know if it helps you, but my rep. don't allow me to post a comment :/


In El Capitan the scale can be changed.

  • Go to View > Distances
  • Select Miles or Kilometers

Maps select distance


Sorry for opening an old topic, but I just had this problem on a new Yosemite computer. I figured out that

  • Irrespective of regional settings, you cannot change the units (View -> Distances) from curious regional units to world-standard units in Satellite mode. But you can switch to those curious units from across the water at any time. Bizarre.
  • In Map mode you can freely switch between the two.

U can change it in the settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .