9

I use the Spotlight calculator a lot but since the upgrade to OS X Mavericks the decimal pointer has changed to a , instead of the . as in a previous release. Probably it now respects some locale setting but I cannot find which.

I reside in a German speaking country but use a US keyboard, the interface is set to English, the region formats are set to United States (with the exception of the currency being set to Euro), see this screenshot.

Language & Region settings

Still, the calculator expects a , as a decimal separator:

1+.5

gives no result, while

1+,5

prints 1+,5 = 1,5

How can I change the decimal separator back to a .?

Edit: As you can see in the screenshot the decimal point is set to . through these settings. Spotlight ignores that setting until you reboot (which I hadn't done at the time).

13

You can change the settings from the Advanced...button in the Language & Region preference pane.

Remember that you have to either reboot or log out for the changes to be applied to Spotlight!

enter image description here

  • 1
    In addition, the free utility Alfred gives you the option of treating both the comma and the period as decimal separators simultaneously. This has come in handy on occasion when I am pasting in numbers formatted both ways. The above is better as a canonical solution. – Jonathan Van Matre Jan 13 '14 at 12:10
  • Well, as you can see in my screenshot (on the right bottom you can see sample values), I have the settings exactly as I want them (grouping ,, decimal .). Still Spotlight only accepts a , as a decimal point. – akirk Jan 13 '14 at 13:34
  • That's strange, I managed to change the decimal separator from here and it got applied when I logged in again or rebooted. – onik Jan 13 '14 at 13:47
  • If you don't like rebooting, kill the SystemUIServer process. Type sudo killall SystemUIServer in the terminal. This will reload the spotlight configuration. – Berik Jul 21 '14 at 9:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .