0

I recently installed a 1TB HDD in my early 2011 13" MacBook Pro using an MCE Optibay. The stock 120GB SSD houses an OSX Mavericks install and a Windows 7 install, done basically via Bootcamp. The 1TB HDD is split into 2 partitions: an NTFS side for Windows file storage and an HFS+ side for OSX storage.

When I'm doing large file transfers (DVD .iso files, my music library, etc) to the HFS side of the drive, usually after about 5 minutes both of the partitions on the drive will unmount and display a message about not being ejected properly. After unmounting, the drive won't show up at all in Disk Utility and the "SATA" section of System Information just displays an unknown device. I've tried disabling the sudden motion sensor in Terminal and telling it not to spin down drives when it's plugged in.

The weird part is that large file transfers work fine on the Windows side, i.e. transferring to the NTFS side of HDD from within Windows.

Any thoughts or advice? I'm considering installing Windows to the HDD, giving OSX full reign of the SSD, and putting a FAT32 shared partition on the HDD. I also have a USB to SATA cable I'm thinking of using to test the drive to see if it's maybe the Optibay or ribbon cable's fault.

  • Please check the SMART status of the drive and also check if any message show up at Console when that happens. – Shane Hsu Jan 13 '14 at 8:43
  • Any issue when you transfer those large files to an external HD? – Andrew U. Jan 13 '14 at 14:55
  • @ShaneHsu SMART status is verified, but when I looked at Console it showed a ton of "mdworker: (Warning) Import: Bad path:" errors, which I assume correspond to Spotlight indexing my NTFS drive? – Marshall Jan 13 '14 at 19:17
  • @AndrewU. I haven't had any problems transferring similar large files to an HFS+ external drive I have. – Marshall Jan 13 '14 at 19:17
0

The answer:

I took the 1TB HGST Travelstar 7K1000 and gave it a firmware downgrade. HGST emailed me application to set the port to either, Sata I, II, or III. Reducing it to Sata II solves the problem.

No more dropping.

Has somethgn to do with Apple/intels first venture into the Sata III world back then. I used the less expensive Opti bay kit. Not the more expensive Extreme they have created to solve the problem.

Works great and is plenty fast for a seconday drive.

-1

I too had this problem. I found a solution in this youtube video. Please check it out. It might solve your issue.

https://www.youtube.com/watch?v=ASV9X8efSkA

After following steps in this video , the random eject issue of 2nd HDD was solved on my Macbook Pro.

  • Welcome to Ask Different! We try to refrain from link only answers, as they decrease readability and are susceptible to link rot. Could you please add any relevant info to the body of your answer? – JMY1000 Nov 24 '17 at 4:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .