6

I install Windows(XP after that 7) on my MBP with Boot Camp and every thing was fine but after a while in System Prefences -> Startup Disk my windows partition was lost and when I want to switch to my windows must restart my Laptop and Press Down option during startup. I can't switch directly from my OS X.

anyone know how can I solve this. or why this is happened?

alt text

  • 1
    +1 for the "Must be here" :-) ... and because I found an answer to my question – DerMike Jan 7 '11 at 13:50
9

Did you by any chance install the NTFS-3G driver?

It's a known bug (for quite some time, now). When installed, you can no longer have the Windows partition in the Startup Disk prefpane.

  • :D Yes I install NTFS-3G Driver, is there any way I Solve this bug? or I must remove this 3rd-party software? – Am1rr3zA Aug 17 '10 at 21:35
  • Unfortunately, there doesn't seem to be any easy workaround. See "Known issue" for possible solution: macntfs-3g.blogspot.com/2010/06/… – Loïc Wolff Aug 17 '10 at 21:40
  • Tanx For your Help, I was really confuse what was my problem and now I find. – Am1rr3zA Aug 17 '10 at 21:54
  • Thank you so much for that! I was extremely curious as to what was going on and I have been looking for a cause/solution for awhile now. – Ryan Wersal Feb 4 '11 at 20:23
0

You shouldn't have to eject your Bootcamp disk from your Desktop. As soon as you do that, it's unavailable to the system until you reboot.

A quick tip: if you don't want your Bootcamp drive to display on your OS X Desktop, boot into windows and then rename your C: drive to a name that starts with a period. OS X will treat it as a "hidden" file and not display the icon. Been using that trick since Bootcamp was in beta and have never had a problem with it.

  • it's good trick but it's not my answer, you said " it's unavailable to the system until you reboot" but I eject my boot camp 3 month ago and I lost it in my startup disk and after that I more than 50 time reboot my laptop and still can't see my Windows partition in startup disk in system preference – Am1rr3zA Aug 17 '10 at 21:24
  • Ah, sorry, I misunderstood. The advice above about an NTFS driver is likely your culprit. – Scottie Aug 18 '10 at 8:05
0

I found a solution, if you haven't already. I'm assuming here that you have already uninstalled the NTFS-3G Driver

Browse to /yourhdd/Library/ and search that folder for a file called com.tuxera.NTFS.plist - I found mine in .../Library/Filesystems/NetFSPlugins

Open that file with a property list editor. I used Open with Property List Editor 2.1

Look for a Property, Disable Driver, change it's value to 1, and restart, should be fixed.

  • you mean, it's not essential to uninstall NTFS-3G driver? – Am1rr3zA Feb 4 '11 at 21:32
0

I had this issue with the latest version of Tuxera NTFS and El Capitan. I reinstalled Tuxera, restarted and all game good again. My bootcamp drive was accessible again via the desktop.

-1

In the NTFS control panel, there is an option to uninstall. I did that, and, without restarting, I have the option again!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .