So for all of the iPhone 4Ses that got the grayed out WiFi problem after upgrading to iOS 7, the only fix that seems to actually work is basically heating up the iPhone up (till about the point it gives a heat warning), then chilling it, and then restarting it. (I've seen this solution in various places, such as this Apple Discussions thread).

But what exactly is happening? Is there still a physically damaged WiFi chip in these devices that the software has been tricked into using? Or is it a weird work around that tricks defective software into working properly?


I have tried this fix and it does work although it wasnt permanent. The only thing I can think it is doing is re setting the base temps of the motherboard and chip, much like a PC. In other words the software might be looking for the difference between the motherboard and the chip temp. If they have set this too low for the 4S then obviously it would show it is overheating even if it isnt. By heating up the motherboard and the already hot chip (which wont heat up further as much) you are re setting the parameters and so it works for a while or permanently. I'll try further.


Drastically changing temperature on electronic components causes solder joints and other connections/components like capacitors, to expand and/or contract. It is usually used as a quick way to diagnose where a problem is.

So in the 4S's case, it may be bad solder joints, a bad capacitor or even the wifi chip (USI 339S0154)'s oscillator isn't calibrated correctly and the change in temperature allows it to change slightly. However I haven't looked at the datasheet to verify this.

It is interesting to note that almost everyone having this problem got it with the upgrade to iOS 7. The only non iOS 7 issue I've come across is in this video, Apple iphone 4s no wifi no bluetooth, but the video is in Italian so I don't know what he is saying, other than that applying heat to the wifi IC seems to fix the issue.

  • I can confirm that my iPhone 4S started to experience problems with WiFi very shortly afterwards I installed iOS 7. I thought that would be a coincidence, but it appears that it's not. – vbezhenar Oct 16 '14 at 18:40

i'll throw in a bit of information i found.

had iphone 4s, wifi was intermittently failing during ios 6. upgrade to 7 killed it. retired to ipod status, got new phone. updated to 8, no change in function. it was working every now and then. used hair dryer while it was on ios 8.00. this fixed it for about a week. upgraded phone to ios 8.0.2. instantly wifi was greyed out. hair dryered it again, and it resumed working.

this verifies something i had read before. that there is a connector to the wifi that is a status/utility channel. if the os can't talk to it (ios7+), then it registers as missing. if you force it to send an overheat/fail signal then it reconnects and finds the wifi hardware again? this gets wiped out on os reinstall.

HOWEVER. i also blew away the connector to the battery with the heat. the low temp solder had melted (it's not even solder, but some low temp joiner) and it was only being held by screws with bad continuity at the pins. batter started acting very intermittently.

sending it away to get fixed now, since it's small/specialized soldering.

be careful with the heat.


The fact that it requires chilling the iPhone in order for the WiFi issue to be resolved means that this remains a hardware problem. iPhone 4 and iPhone 4S were simply not intended (or sufficiently tested) to be run with iOS 7 and this makes the WiFi chip overheat.

It's the first time I hear the heating trick. A normal chilling (i.e. putting the iPhone in the fridge) has worked for me in the past. Heating the device might break something further.


I had this problem in my iphone 4S with IOS 6.1.3. Chilling only works temporarily.

I tend to agree with the theory of lose soldering or connections, which are helped by heating.


I had the usual iPhone 4s symptoms: WiFi greyed out, degraded BlueTooth, very high battery drain.

After updating everything and checking each app I finally tried the hair dryer but mine was too weak. I used my heat gun with the temperature on moderate. After 5 minutes the corner of the display started to blacken but would recover as soon as I took the heat away. I held it with the top 1cm mostly black but gave up at 10 minutes without getting the over-temperature warning. I did a hard reset and left it to cool. When I turned it back on all the problems have gone and all it working 24 hours later.

So I still don't know why it worked but I add my story to the data mix. Maybe someone will work it out. It can't be a hardware failure or it couldn't be fixed without replacement. If it is purely software why did my attempt fix it? I suspect an aerial connection problem cause part of the OS to stay in a loop. I think I was running 7.0.3 for a while before the issue. 7.1 changed nothing. While I had the problem a number of settings pages were quite slow to load: 'settings', 'general', 'personal hotspot'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .