1

I recently purchased a Mac mini and have begun having a problem with bluetooth. I've made a bunch of changes to the system all at once, so some of the information I'll provide is probably not relevant.

I am currently running 10.8.5 (12F45) off of a new second hard drive that I installed (a Crucial M500 SSD). I have an Apple Extended Keyboard with an iMate ADB/USB adapter and a Magic Trackpad as my input devices. I had used this Magic Trackpad and keyboard with a MacBook Pro (running Lion) for about two years without any problems.

The problem that I have encountered is that occasionally (not every time), when I wake the computer from hibernation (which it automatically enters after a brief period of sleep overnight), bluetooth is malfunctioning in a strange way. Bluetooth is indicated as on in System Preferences and in the menubar, but cannot be turned off. The trackpad is not indicated as connected. Here's the strange part: the trackpad still partially works. I just used it to wake the computer (not the power button). I can move the cursor around the screen and click on things if I press on the trackpad, but none of the gestures work – scrolling, swiping, zooming, etc. and I can't tap to click. When I go to the Trackpad preference pane, it thinks no trackpad is connected, and when I go to the Bluetooth preferences, the name of the bluetooth module shows as:

"Name not available"

Here's what I've tried so far:

  • checked software update to make sure all updates are installed
  • unpaired trackpad from MacBook Pro
  • unpaired and repaired trackpad to Mac mini
  • reset NVRAM and SMC
  • killing blued process

None of these has had a lasting effect; killing blued never worked.

One of the things I've noticed is that when I wake the computer and this condition occurs, I see the following two messages in the Console:

kernel[0]: [AppleMultitouchDevice::willTerminate] entered
kernel[0]: [AppleMultitouchDevice::stop] entered

Whereas normally when I wake the computer, I get these two messages:

kernel[0]: [AppleMultitouchHIDEventDriver::start] entered
kernel[0]: [AppleMultitouchDevice::start] entered

I'm kind of at my diagnostic wits-end. I'm willing to try a fresh install of Mountain Lion, but I'd kind of like to know why this problem is happening so that I'm confident a reinstall will be a permanent fix. Thanks in advance for the suggestions.

  • Just in using the computer for the past week or so, I have some anecdotal evidence that these problems with bluetooth might be caused by me trying to wake the computer from hibernation using the keyboard. I think the rush of keyboard inputs coming over USB might be interfering with the restart procedure of the bluetooth module. I will confirm with System Profiler this evening whether this is a possibility. – trynthink Jan 17 '14 at 16:04
  • Alright, that definitely wasn't the cause. One other thing I've noticed from the Console log is that I get several lines of: blued[72]: BluetoothHCIWriteExtendedInquiryResponse returned 12 anytime bluetooth fails. – trynthink Jan 18 '14 at 3:36
0

As it turns out, the problem was one with either the iMate ADB/USB adapter or the Apple Extended Keyboard (AEK). Since the AEK requires an ADB/USB adapter, and I don't have another one around, I can't determine which component was the cause. Either way, since I replaced the AEK with an Apple USB Keyboard, the problem has not returned.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .