I'm encountering latency trouble with my 15" 2011 Macbook Pro (running 10.6.7) when on an 802.11n (5GHz) wireless network hosted by a Time Capsule (version 7.5.2). When I ping the Time Capsule, the ping numbers are all over the place, like so:

64 bytes from icmp_seq=216 ttl=255 time=3.461 ms
64 bytes from icmp_seq=217 ttl=255 time=236.725 ms
64 bytes from icmp_seq=218 ttl=255 time=157.924 ms
64 bytes from icmp_seq=219 ttl=255 time=79.511 ms
64 bytes from icmp_seq=220 ttl=255 time=1.295 ms
64 bytes from icmp_seq=221 ttl=255 time=0.833 ms
64 bytes from icmp_seq=222 ttl=255 time=150.669 ms

226 packets transmitted, 226 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.718/115.353/303.004/96.717 ms

The location of my computer doesn't seem to matter. My signal shows up consistently at four bars, and I get the same ping results whether I'm in a different room, different floor, or right in front of the Time Capsule.

A second 15" unibody Macbook Pro (Mid 2009, also running 10.6.7) doesn't have this problem on the same network. All pings to the Time Capsule from this second machine report <4 ms.

If I connect my computer via ethernet to the Capsule, I get a solid <1ms ping, as expected. Only the wireless appears to have wild jumps.

I have tried resetting my network settings (deleting all network configurations from the library), disabling IPv6, changing my "Network Location", resetting the PRAM, resetting SMC, recycling power on the Time Capsule, but none of it seems to have had any effect. I've tried to make sure I have no programs running in the background - Software Update has been turned off and running lsof -i on Terminal only reports SystemUIS as having two open IPv4 connections. There is also no significant network traffic taking place, so it's not a matter of congestion.

Any ideas on something else I can try? I'm sort of at a loss as to why one computer is fine and this one is not.

  • I encountered the same issue with 10.10.5 and 10.11.2. – Henry Yei Feb 5 '16 at 1:43

Edit: Apple released two updates for the MBP this week, including an EFI update. While neither update explicitly mentioned wireless connectivity, the update seems to have partially fixed the problem. After installing both updates, I get a pretty consistent 3-5 ms ping with a very very occasional spike to 100. At least it's much better than before.

In the meantime, the trick below still works if you want a 1 ms response instead.

There's an interesting tip from someone on Apple's discussion forums that can work as a workaround.

It appears that if the network card is inactive for more than 200 ms, it powers down and has to be powered up to send network traffic again, hence the random spikes. But, if you can keep the network card active (at the cost of a small amount of CPU power and some extra traffic), then the latency goes away.

The command recommended by seanfromcolumbus was:

sudo ping -i .2

(The -i .2 specifies an interval of 200 ms)

Indeed, with this running, I get consistent results of <2 ms.

Original Post

  • 3
    Not everyone's router is The command I wrote for myself is ping -i 0.2 `netstat -nr | grep -m 1 '^default' | awk '{print $2;}'`, which should work under all circumstances. :) – fletom Feb 6 '14 at 7:23

I did a Time Machine backup and wiped out my existing installation then did a fresh install of Snow Leopard. After that I installed the 10.6.7 combo update just to verify that it was the cause of this problem and it IS! I did yet another fresh install and then I only installed the 10.6.6 combo update and the rest of the regular application updates. Now everything is back to normal. With 10.6.7 I was getting insane ping response times back from the gateway... like 350ms...800ms..600..245.. etc... now everything is back to normal and I get the expected <1ms or the random 1-5ms... I don't know what Apple did with 10.6.7 but it destroy's wifi.

  • Interesting, so it's from the 10.6.7 update then? I suspected it was a recent problem as I hadn't noticed so many network issues a few months ago, but I also changed computers so I wasn't sure. I guess until Apple fixes it, I'm stuck choosing between my computer freezing up when changing between GPUs on 10.6.6 or losing connection in games because of latency spikes in 10.6.7. – Troyen Apr 12 '11 at 2:30
  • This is still an issue. I am on 10.11.5 and the latency to the router still happe. Event with the sudo -i .2 the latency is there. It just happen on different time intervals. – kode Jun 23 '16 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .