5

When typing in a rich text format form in an application (such as the Notes app, Mail compose message dialog, Evernote) my Mac automatically corrects two or three dashes (--) into one long dash (—).

I don't want this behaviour because I manage my time using a plain text based system that I have been using since several years ago. The latest update to 10.9 changes this behavior.

I have tried looking into the Keyboard settings, I have turned off Correct spelling automatically option in Text settings to no avail.

  • 1
    I am interested to disable this feature just in Notes, maybe even forcing it to use a simple font/drop the formatting. – sorin Oct 9 '14 at 8:57
9

Nevermind, I have found the answer to my problem. As I was writing the question, I found another setting under Keyboard > Text; Use smart quotes and dashes.

This option is probably set to true by default. Leave it unchecked and the problem is solved.

I actually clicked Post your question and answer when submitting the question, but somehow the answer doesn't show up.

| improve this answer | |
1

Actually, all you need to do is go to Languages Preferenses and select Keyboard. Then select Text. You will see a column marked replace with. On my system there were some default shortcut phrases (i.e. "where are you?") and I simply deleted them. No need to uncheck the smart quotes and dashes.

| improve this answer | |
  • I have seen this table before, and unfortunately it doesn't solve my problem. The table does not have an entry to replace three dashes with one long dash, but the system does it anyway. So for me the solution is still to disable the Use smart quotes and dashes option. – avee Jun 30 '14 at 3:39
1

If it is just for Text Editor, go to Preference - Plain Text and uncheck Smart Dash. It work for me and no need to turn off for all Apps in System Prefs.

| improve this answer | |
0

The Pages app has a separate auto-complete (called substations) configuration which is accessible from the Edit > Substitutions > Show Substitutions menu.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .