3

I love the improvements that Apple made to multiple displays in Mavericks, but there is one thing that really gets on my nerves. If I'm using an application on my secondary display, and I use spotlight to open a new application, I want it to open on my primary display, not the display that was just active. Unfortunately, the only way that I know of to fix this is to disable separate spaces for each display, which I use very frequently. Is there any way that I can force all of my applications to open on the primary display (the one with the menu bar in the Displays preference pane)?

1 Answer 1

2

I don't fully understand your question but here's my answer on what i think you want to achieve. Make sure you have your display connected when doing the following.

  1. Open the application you want to assign.
  2. Control+Click(Right click) on the dock icon
  3. You should see that a menu pops up and hover over Options
  4. You'll see something that says Assign To and then some options
  5. Select the display you want
  6. You should be done :)

On my screen

4
  • I don't see that at all. I probably should have clarified my question. See the edit I am about to make. Jan 10, 2014 at 12:55
  • I'm running the latest version of Mavericks, and I see it. Did you right-click on the application's icon in the dock? Then you should see options and the "assign to"
    – Downgoat
    Jan 11, 2014 at 15:43
  • I added a screenshot.
    – Downgoat
    Jul 20, 2014 at 19:52
  • Nearly a year later, I have finally discovered this option. I started using an iMac as my primary display for my MacBook, and that is when this option appeared. I have since started using it. Previously, I was using two Dell monitors as external displays and they did not make this option appear. Nonetheless, thanks for your help! Dec 19, 2014 at 6:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .