When I change the volume using the buttons on an Apple Wireless keyboard (with a Mac Mini) I almost have a huge delay between the key press and the action (up to several seconds and from time to time even several minutes).

  • using the slider on the menu works perfectly (without delay)
  • resetting the PRAM does not bring any improvement
  • I do not have any sound-related third party utility as boom (see an Apple Support discussion)

Any idea what the cause could be?


  • Brightness is affected as well
  • I also noticed that the process loginwindow is not responding and uses 100% of one core
  • The console shows no errors
  • I guess you get the same behaviour with the brightness ? Commented Jan 9, 2014 at 17:21
  • @MatthieuRiegler I will check I almost never change it, at the moment they both work. I will wait a couple of hours and when the strange behavior comes back (it always does after a certain time) I will check if the brightness is also affected.
    – Matteo
    Commented Jan 9, 2014 at 17:25
  • I'm seeing this issue as well. Started happening yesterday. Running 10.9.4 on iMac. Disconcerting as I adjust my volume and brightness often to accommodate different programs.
    – SMBiggs
    Commented Jun 29, 2016 at 6:10
  • worked immediately!
    – nullwriter
    Commented Oct 17, 2020 at 9:59

8 Answers 8


Typing sudo killall coreaudiod in the terminal fixed the issue straight away for me.

It also removed the delay on the keyboard brightness buttons. Issue started after going back to internal speakers after streaming audio through airport.

  • 5
    Sometimes it just doesn't restart by itself, in that case just do: sudo launchctl unload /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist then sudo launchctl load /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist
    – Buzut
    Commented Oct 5, 2016 at 16:55
  • This didn't work for me. However restarting my computer did it for me. It had been running for 40 days.
    – neoneye
    Commented Jun 10, 2017 at 8:51
  • Didn't work immediately, but after a few seconds it was working
    – shim
    Commented Jul 3, 2017 at 19:18
  • 1
    After I did this (High Sierra) the audio stopped working and I got the prohibition symbol at the bottom of the toast popup when changing sound, so I went into sound settings and switch the output to a different device and back and then it worked.
    – shim
    Commented Nov 15, 2017 at 18:53
  • sudo killall coresymbolicationd Help me for keyboard brightness buttons.
    – kitta
    Commented Jul 1, 2020 at 17:33

In your sound preferences go on the 'Sound Effects' tab and turn off 'Play feedback when volume is changed'.

This solved the delay for me. Seems it was taking a second to read the sound effect from disk each time.

  • 1
    +1 I am not able to check since I no longer have the Mac Mini with the problem, but it seems a valid approach (the delay because of the disk could have been a problem).
    – Matteo
    Commented Mar 31, 2017 at 16:39
  • 1
    Worked for me too on my MacBook Pro running 10.12.6
    – bpanulla
    Commented Mar 20, 2018 at 17:30
  • This worked for me too.
    – JRajan
    Commented Nov 15, 2018 at 8:11
  • Correct solution to fix the delay between the keyboard hit and the change into the volume. Thanks!
    – ikocel1
    Commented Feb 17, 2020 at 8:26

Killing coreaudio did not work for me.

But then I have noticed that this behavior happens when running Android Studio connecting to an Android device. Apparently the ADB (Android Debug Bridge) has some conflict which causes sluggish behavior with the volume and screen brightness function keys.

Solution: Shut down Android Studio and disconnect the device. Make sure that Android Transfer program is not running either (it'll show up in Activity Monitor). Yeah, it's not an optimal solution, but it works for me.

I don't expect many of you to be Android programmers, but if you are, this just might be the fix you're looking for.


There is a bug in OSX 10.10+ that makes the volume and brightness buttons depend on CPU/disk. A fresh install on new hardware under load will have this issue. Downgrading to 10.9.x, hoping 10.14 fixes it or installing Linux are the only solutions I am aware of. Apple had no comment, and is unlikely to fix it as new hardware contains SSDs that hide this issue.

  • The problem was there in 2014. 10.10 was not yet released.
    – Matteo
    Commented Jun 16, 2015 at 5:37
  • Now I have a different OS but also a different machine ...
    – Matteo
    Commented Jun 17, 2015 at 12:47

I have found that delays from the Apple wireless keyboard or mouse are Bluetooth related (ie interference). My Apple Watch rarely unlocks my laptop but each time it tries my mouse becomes very laggy. I'd suggest disabling Bluetooth on nearby devices which are not actively using Bluetooth to perform actions. Likewise, check for anything which could be causing signal loss, large metal objects or electrical items.


Do you have an APC UPS?

I was having this exact problem after upgrading to Mavericks yesterday, and found that force-quitting apcupsd (a UPS controller daemon) instantly removed the delay.

If this doesn't help then you could try force-quitting other third party daemons that perform similar tasks to apcupsd.


Next helps:

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist
sudo launchctl load /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist
  • 1
    /System/Library/LaunchDaemons/com.apple.audio.coreaudiod.plist: Operation not permitted while System Integrity Protection is engaged. Unload failed: 150: Operation not permitted while System Integrity Protection is engaged
    – Henno
    Commented Oct 6, 2021 at 17:34

restart worked for me: both volume and brightness controls fixed.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .