1

Occasionally when I start up my Mid-2012 Macbook Pro, I see the following error messages a few moments after logging in:

IOStorageFamily.kext cannot be used IOSCSIArchitectureModelFamily.kext cannot be used

This happens about every second or third login. After seeing these error messages, I sometimes have trouble using external USB storage - the power lights on the storage devices will come on, but my laptop doesn't seem to recognize and mount the volumes. I'm savvy enough to know what kernel extensions are and what their purpose in the OS is, and I can tell from the kext names that these relate to external mass storage, so that makes sense.

What I don't know, however, is what can be done to fix this error. Has anybody else encountered this problem?

I'd rather not reinstall the OS if I can get away with it, but I will if there's no other solution - maybe something involving kextutil?

Edit: I may have just solved my own problem: Running a "Repair Permissions" task in Disk Utility results in the following: disk utility screenshot As you can see, Disk Utility repaired a number of bad permissions in IOStorageFamily and IOSCSIArchitectureModel - we'll see if the error messages stop occurring as a result.

  • Did you have to install any software when you got your drives and attached them the first time? What drives are they? – Andrew U. Jan 9 '14 at 16:08
  • The problem is with any USB mass storage device - flash drives, external hard drives, et cetera. I haven't installed any third-party device drivers for storage devices. – Eliza Weisman Jan 9 '14 at 16:10
  • I was afraid of that. Have you tried installing the OS? – Andrew U. Jan 9 '14 at 16:11
  • @AndrewU: I'll reinstall if it's absolutely necessary, but I figured it was worth asking to make sure there isn't any other solutions first. – Eliza Weisman Jan 9 '14 at 16:13
  • How comfortable are you with terminal/unix? – Andrew U. Jan 9 '14 at 16:15

You must log in to answer this question.

Browse other questions tagged .