2

I am running a web server locally, and I can reach it by typing

http://localhost:63342/myproject/index.html 

(this server is automatically started when I work on a web project in the Webstorm IDE by Jetbrains...)

Replacing localhost with 127.0.0.1 also works fine.

However, if I use the IP address (at this time of writing, 10.0.1.13) assigned to my macbook by DHCP for the wifi-network I am connected to, I am unable to connect to my site. My router is an Apple Airport Extreme with no particular configuration other than the default settings. Why is this not working?

My ultimate goal is to open this web site in browsers on different mobile devices on the same wifi-network, but then I at least have to make it work from the same computer hosting the site (I have tested with a mobile device and I fails in the same way)

  • is port 63342 open on your router and is it none that is has to point to the macbook? – Andrew U. Jan 9 '14 at 15:35
  • Is it listening for connections on all IP addresses, or just the local loopback addresses? Run the command netstat -an | grep 63342, and see if it lists tcp4 0 0 *.63342 (and probably a similar "tcp6" line) (all addresses) or tcp4 0 0 127.0.0.1.63342 and maybe tcp6 0 0 ::1.63342 (just the local loopback addresses). – Gordon Davisson Jan 9 '14 at 16:40
  • I get three lines using your command. 1: tcp4 0 0 127.0.0.1.63342 127.0.0.1.55770 ESTABLISHED 2: tcp4 0 0 127.0.0.1.55770 127.0.0.1.63342 ESTABLISHED 3: tcp4 0 0 127.0.0.1.63342 *.* LISTEN – Tore Jan 9 '14 at 22:09
1

Problem solved. I had to enable the option of accepting external connections in Webstorm settings.

Screenshot from the Webstorm IDE showing how to enable the option of accepting external connections

  • When I change the Built-in server port from 63342 to 3001, it worked. – corochann Aug 30 '16 at 2:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .