1

Recently to solve a problem I have been encountering related to iCloud, I had to sign out of iCloud and sign back in.

Normally I have all the options enabled except for mail. When I signed in I started enabling all of the features and came across a problem where if I were to attempt to enable Calendar while Reminders is enabled, Calendar would say the words "Setting Up" and a spinner would appear and the checkbox would be greyed in. After about 20 seconds the words, spinner and checkbox clear away leaving Calendar still disabled.

This works the other way around if Calendar is enabled first and I attempt to enable Reminders.

I have tried extremely basic things such as rebooting the system to clearing the cache files in the libraries but still nothing. Anyone got any ideas on how to fix this? Thanks!

0

It's your firewall...I have TCPBlock on my system and encountered the exact same thing. Make sure you're allowing any sync services and iCloud to communicate with the outside world.

  • I have no firewall modification on my system at all. No 3rd party programs are installed and the inbuilt firewall is left at its default settings (off). – SteppingHat Aug 2 '15 at 16:16
0

Solved this problem a while back, but this was resolved by clearing all the iCloud cache files, along with system cache (local user library) and system library cache (though it may of not have been needed.)

Whatever was in the cache must have been accessed by the services upon enabling them and treating it as all valid data without any checks, even though it may have been corrupt, outdated, mismatch or whatever other reason. I assume this was the cause as removing all cache directories such as ~/Library/Caches being the best place to start.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .