3

I have had an iCloud account associated with a Gmail ID old@gmail.com. I then switched to another ID new@gmail.com, so I removed old@gmail.com from my iCloud account and entered new@gmail.com. This was an year or so back.

A few days back, I found an entry in the Keychain for old@gmail.com, so I deleted it. After that, I'm prompted one every reboot to enter the password for old@gmail.com:

enter image description here

I cancel it, but it comes up after every reboot. I tried entering my iCloud password, but it doesn't work.

How do I get this prompt to go away and never come back?

  • 1
    Have you confirmed that everything is setup correctly at the Apple ID website: appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa? – bassplayer7 Jan 8 '14 at 14:49
  • Sorry for the late reply (I think I missed your comment earlier). Yes, everything is set up correctly there. old@gmail.com is not listed. – Vaddadi Kartick Mar 18 '14 at 12:32
  • ... And the problem seems to have disappeared, maybe with the 10.9.1 or .2 updates. Thanks for your help, bassplayer7. – Vaddadi Kartick Mar 18 '14 at 12:39
  • Great to hear that everything is working correctly now. – bassplayer7 Mar 18 '14 at 18:19
1

The application icon suggests the password is being requested by Messages.app.

Messages.app

Launch Messages.app and check the accounts listed in the preferences do not include or mention your stale @gmail.com account.

Messages preferences toolbar

Internet Accounts

Look for legacy accounts in your Internet Accounts within System Preferences.app:

System Preferences > Internet Accounts

Preferences

Check your preferences for mentions of the old address using the Terminal.app command:

grep -r old@gmail\.com ~/Library/Preferences/*

If this matches a file, modify the following command to examine the file's contents:

defaults read ~/Library/Preferences/MobileMeAccounts.plist > ~/Desktop/output.txt

In the example above, a new file called output.txt will appear on your desktop. This file can be opened with TextEdit.app.

This file may hint as to which application or tool has your old account listed.

If you find a matching preference, consider deleting or renaming it. The preferences will be lost but they should never contain critical information.

Remember to log out or restart after altering the preferences file.

  • That didn't help -- it lists new@gmail.com, and not old@gmail.com, but Apple confuses new@ for old@gmail.com. Turning my account off and on in Messages produces that prompt again asking me to type the password for old@ – Vaddadi Kartick Jan 8 '14 at 14:23
  • What do you see if you run the following Terminal.app command: grep old@gmail\.com ~/Library/com.apple.imservice.iMessage.plist? – Graham Miln Jan 8 '14 at 15:23
  • grep: /Users/kart/Library/com.apple.imservice.iMessage.plist: No such file or directory – Vaddadi Kartick Jan 9 '14 at 5:42
  • Sorry, my last command missed a folder. How about if we widen the search: grep old@gmail\.com ~/Library/Preferences/* ? – Graham Miln Jan 9 '14 at 7:07
  • 1
    Sorry, I seemed to have dropped the ball on this. The problem seems to have disappeared, maybe with the 10.9.1 or .2 updates. I no longer get the prompts, and old@gmail.com is no longer in the plist file. Thanks for your help, Graham. – Vaddadi Kartick Mar 18 '14 at 12:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .