By mistake, I clicked on "always allow" on a file in my keychain on the Mac. How do I undo this and restrict access? I tried to correct it by clicking on Access Control. There I selected "confirm before allowing access" but it didn't work. I can still see the password for that file without entering a password.

You should be able to clear out any white listed programs and then reset the default behavior from Keychain Access.

enter image description here

  • First select Fantastical (or any apps that are cleared) and then press the -
  • Second, choose Confirm and Ask as needed.
  • Third, select Attributes and make sure the changes are saved (you should probably have to authenticate as well at this step)
  • Go back to Access Control to verify the settings have been saved properly

If this doesn't work, you might need to repair that keychain containing that item, also using Keychain Access menu to open the Keychain First Aid tool.

  • 2
    I don't know if this is still valid or if you might be able to add how exactly to get to this screen. Whenever I open "Keychain Access" from Spotlight Search, I get a screen for dealing with system certificates. I'm not sure how to get to the exact image that you are showing in your answer. Could you add how to find that "Access Control" window? – zero298 Jul 27 at 15:39

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.