I have Mac Os X 10.9 Mavericks. I want to write to NTFS drives. I followed the instructions here.

The following command was not allowed to run:

$ sudo echo "UUID=7575C85E-F6F7-4ABD-B7FB-6180B795DD81 none ntfs rw,auto,nobrowse" >> /etc/fstab
-bash: /etc/fstab: Permission denied

What should I do to edit /etc/fstab?

5 Answers 5


You need sudo to perform the write to /etc/fstab and not the echo. Try:

echo "xyz" | sudo tee -a /etc/fstab > /dev/null

I added the > /dev/null to suppress the echoing of the long UUID (which I abbreviated "xyz" for clarity's sake). You can skip the > /dev/null part and it will function the same as the command you listed.

echo "UUID=7575C85E-F6F7-4ABD-B7FB-6180B795DD81 none ntfs rw,auto,nobrowse" | sudo tee -a /etc/fstab



You could use an editor under sudo

e.g. for nano

sudo nano /etc/fstab

Then copy the line from somewhere to the clipboard and then use paste to paste into the edit session. Then save.

  • I might reject your emacs and substitute vi but perhaps we can all agree to mock Apple that typically nano for editing system files? manuals.info.apple.com/MANUALS/1000/MA1173/en_US/…
    – bmike
    Jan 4, 2014 at 19:06
  • 3
    I suppose the attempted joke at "editor choice religious wars" would be better placed somewhere else... Fos someone not comfortable with command line - nano is the perfect choice IMO.
    – bmike
    Jan 4, 2014 at 19:17

In OSX 10.9 the file /etc/fstab does not exist, so I just create that file and works perfectly.

Just don't be confused (like me) with a file called /etc/fstab.hd.


Ummm, last time I heard writing to NTFS volumes is not fully supported by Apple as evidenced by it not being enabled out of the box. So proceed with caution.

A quick google search will yield several third party drivers (free and paid) that enable writing to NTFS drives.


That's the number one hit in google, there are a lot more. But if you want to live dangerously then go for it! ;-)


My mac won't let me access /etc/fstab, and hfs.util won't even show me what the UUID is.

I'm on Mac OS X 10.6.8 and bought NTFS 4TB Seagate USB3.0 drive. Plugged in, Mac allowed me to read files from it, but not write to it. When I select 'Get Info' for the volume/disk, I see 'You can read only' under 'Sharing & Permissions'.
I copied a large file from Windows 10 to the USB Drive, worked fine. I then downloaded the file to Mac, worked fine, but won't allow me to write anything from Mac to the USB drive, or make any changes to it eg. delete or rename files on the USB drive. My reason for getting this USB drive formatted in NTFS was to copy files from Mac larger than 4GB to Windows for redundant backup, because of 4GB limit in FAT.

One solution I found online was to sudo echo UUID to /etc/fstab When I diskutil info, I don't get UUID. I also see the following extracts:

File System Personality: NTFS Type (Bundle): ntfs Name (User Visible): Windows NT File System (NTFS)


Read-Only Media: No Read-Only Volume: Yes Ejectable: Yes

My solution was to download Samsung NTFS for Mac Driver from: https://www.seagate.com/au/en/support/downloads/item/samsung-ntfs-driver-master-dl/

After installation & reboot, I noticed the following changes:

  1. When I select 'Get Info' for the volume/disk, I see 'You can read and write' under 'Sharing & Permissions'.

2. File System Personality: UFSD_NTFS Type (Bundle): ufsd_NTFS Name (User Visible): Windows NT Filesystem

3. Read-Only Media: No Read-Only Volume: No Ejectable: Yes

The readme file (pdf) that comes with the download says NTFS features also work in Mac for the USB drive. Now I can read/write to the disk, and is also visible in Finder. I've tested read & write speeds with a 2GB file, and don't see any difference in performance/speed between the NTFS & HFS+ Journaled volumes.

Finally after 2 days of reading about sudo, hfs.util & diskutil, I can now get back to backing up data from Mac 10.6 to USB NTFS drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .