I have an old Leopard MBP and a 2013 Mavericks iMac.

I want to install Mavericks on the Leopard MBP, but had no success since.

Here's what I did.

  • I downloaded Mavericks from the MAS on the iMac
  • I formatted an 8GB USB drive (naming it Untitled) through Disk Utility
  • I ran this in the terminal: sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app/ --nointeraction
  • The creation of the bootable USB was successful, so I booted the MBP using the newly created USB drive
  • I formatted the MBP internal HDD via the Disk Utility on the Mavericks drive
  • I ran the Mavericks drive installer

Near the end of the Mavericks installation, I ran into the "This copy of the Install OS X Mavericks application can't be verified. It may have been corrupted or tampered with during downloading." error.

I re-downloaded Mavericks from the MAS and tried again; same error.

What should I do now?

  • I have seen a bug several times where when you format a drive using 10.9's installer Disk Utility it reformats it saying HFS+ journaled but it really just does HFS+. Could this be the case with your system? – Andrew U. Jan 13 '14 at 15:31
  • If you don't need the iMac maybe just boot up your MBP in target mode and attach it via firewire to the iMac so that the 10.9 installer runs directly on it that way. – Andrew U. Jan 13 '14 at 15:31
  • As I answered, it was just a probably bad USB drive. – whatyouhide Jan 13 '14 at 20:14

Check that the date is correct. This is an error that can be received if your date is set utterly incorrectly, typically due to a flat battery prior to install and not being able to connect to an NTP server to correct.

  • As I answered, it was just a probably bad USB drive. – whatyouhide Jan 13 '14 at 20:14
  • I'm sure it was if changing it fixed this, but my answer may help others (like me) who had the exact same error, and may find this fixes the problem as it did for me. – stuffe Jan 14 '14 at 10:29
  • 1
    In my case, it was the date issue, I had to follow the following advice: bensmann.no/changing-system-date-from-terminal-os-x-recovery and it worked! – user77194 May 1 '14 at 22:53
  • Just stumbled on the same problem here...used the Date change and worked like a charm! – user85033 Jul 14 '14 at 21:51
  • I found the date has to be a specific range. While I do not know the range a date in 2017 is not valid. I set a date using the recommendations in this post to be in 2015 and it worked. – cgseller Jan 7 '17 at 16:59

It looks like the Mavericks installer is making a verification of an authenticated checksum with a certificate. If your date is out of scope of this certificate window of validity this process fail.

Look at: Jonathan Mohar receipe to fix a sadistic error message.

A more usefull error message might have been: The certificate of your Mavericks installer can't be verified. Check that your date and time are corrects.

The checksum validation should have been made much sooner in the installation process :{.

The problem is the system date when you do a clean install, so open the Terminal (Utilities > Terminal) in the start up screen (where you select to install the fresh os).

Set the correct date, assume that todays date is 2014-10-08 21:00 using the following format: date [month][day][time][year])

In the Terminal window, type: date 100821002014 and hit enter.

Refer to this link on Apple discussions.

  • This worked for me. For some reason the MacBook Pro was set to Jan 1st 2001. The internal drive was completely blank so I had to do this from Terminal within the restore screen. – squarefrog Jun 9 '15 at 9:17

downloaded and created the USB over 10 times with the same error, then found this simplest solution of all, http://www.youtube.com/watch?v=rvd1D1291R0

The solution in the video is to open Terminal from the installer boot environment's menu bar, and enter the command "date 021214152015". Then Install OS X from the menu menu as usual.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Aug 11 '14 at 16:32
  • Please summarize the information in the link you posted, don't just post a link. Content at the end of links can disappear over time making your potentially useful answer, useless. For more information on how Ask Different and the StackExchange Q&A format works please see our FAQ. – Ian C. Aug 11 '14 at 16:40
up vote -3 down vote accepted

For me, the solution was to just change USB drive.

  • I bet that this USB isn't corrupted but was loaded with an image signed on the 1st january of 1970. This isn't a good reason to send an USB key to the trash :). – daniel Azuelos Jul 14 '14 at 22:55
  • I actually found that the date is sensitive and can not be too modern. I had set my date to <2016 and it worked where if it was the absolute time it failed. – cgseller Jan 7 '17 at 16:58

protected by Community Oct 21 '14 at 0:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.