2

After setting up a managed user on my daughter's laptop [2008 macbook pro, OSX 10.9.1], I tested that application and website logging worked - I was able to go into Parental Controls, bring up the Logs... window, and view activity for that account.

A week later, when I open the same Logs... dialog up it's always blank. No applications, websites, etc. are displayed regardless of the time period I select.

It's possible but unlikely that she did something deliberate to break parental controls. For instance, maybe one of her friends showed her a "hack" that uses root access via Single User Mode to break logging? But I don't think this is the case.

I've also read Apple community forum posts that suggest that Parental Controls is broken, but they appear to be for prior versions of the OS.

Other clues, possibly related:

  • Event logs are present in the appropriate place but nothing new is being logged (latest directory is 2013/12, it's now 2014/01)

  • I have the computer set up to do remote management of parental controls, but when I open parental controls on my own mac it does not show her laptop as an "other computer" to be managed.

  • There's no evidence of parentalcontrol service failures in system.log

Is there any comprehensive list of files, chmods, etc. that I can use to verify that parental controls are working and/or watch its operation for errors?

0

I have not tried this solution yet, but there is an Apple support thread here that mentions blank logs, that offers a solution. Here is the solution outlined in that link:

  • Log in as administrator to Parental Controls.
  • Select the child's account.
  • Click on the "settings" button (at the bottom of the white box, beside the "-" sign) to Turn off Parental Controls for the particular child.
  • Re-enable them (click "+").
  • Repeat for all children - one by one, if you have multiple kids....
  • Restart the computer.

I as soon as I kick my kid off the computer tonight, I plan to try this and I'll report back and/or update my answer.

1

I ran into this same problem with my son, I googled and found a post where someone suggested to check

MacintoshHD/Library/Application Support/Apple/ParentalControls/Users

But when I did I found that "Users" was locked. I tried to chmod the settings to 777 and was blocked, so I sudo changed the settings with:

$ sudo chmod 777 Users/

For the non-native terminal user, first open the terminal by searching for it with Command SpaceBar. Type terminal and open it. Then type (hitting enter between each line):

cd "/Library/Application Support/Apple/ParentalControls"
sudo chmod 777 Users/

Then access the parental controls through Settings. You should see the webpages now when you click Parental Controls, then the child's account, then Logs (lower right corner), then Web.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .