17

After upgrading SSD and traveling with my Macbook Pro and traveling while low temperatures outside (I don't know if this is relevant).

When I connect headphones the sound on the left one is significantly quieter.

Is it connector problem or not ? Should I try to put something to the hole, and bent a little bit connectors ?

37

I found out it was volume setting problem, that could be changed in "Audio MIDI setup"

Plug in the headphones (if there is problem with headphones - if problem exists when using internal speakers, don't plug headphones)

Find in Spotlight "Audio MIDI setup" app:

Results from Spotlight

And open app :

Audio MIDI setup app, wrong settings

Make sure that channel 1 and 2 have THE SAME volume set up. Set every channel to value "1" as here :

Audio MIDI setup app, appropriate settings

I have no idea how this disproportion in volume happened. But I would like to know. (I haven't tinker with volume before - except simple volume up/down via headphone control or keyboard's function keys)

This answer is based on the "The Hefster's" answer from :

https://discussions.apple.com/message/18797385#18797385

The Heftster's answer from Apple Discussion page (I post screenshot because https://discussions.apple.com doesn't support linking to stand alone posts)

  • This is awesome. I had something similar happen and it took quite some time to figure out why one channel was attenuated. – bmike Apr 1 '14 at 17:31
  • If anybody would be able to "extract" problem, it would be nice to post it to bugreport.apple.com – Paul Brewczynski Apr 19 '14 at 2:37
  • For what it is worth: setting the two channels to the same value sounds a little off to me. Your 18.5dB difference is pretty big, but after listening to a few tracks I settled on a 3dB increase on channel 2. (all proper disclaimers about your milage may vary etc. &c. ) – dwightk May 21 '14 at 16:23
  • 3
    You are a saint!!! I thought I was going crazy / losing hearing. – Wes Johnson Dec 1 '14 at 22:35
  • 1
    Notice that you can achieve the same effect by changing Settings->Sound: Balance. Also, to quickly exclude hearing impairment as a cause, wearing headphones upside down with right/left switched is a simple test. Finally, encountering the same problem on two different Macs (with balance always at neutral already), let me trace the problem to just headphone plug/cable--unless MacOS does something weird cross-machine... – marco Oct 31 '17 at 13:19
1

Weird solution but it worked for me. I noticed one of the 'holes' of my right EarPod played sound a lot softer than the others did. In my rather desperate attempt at getting it to work properly again, I tried blowing and sucking in to it. It did the job, hopefully it will for you as well.

You must log in to answer this question.

protected by Community Aug 8 '15 at 21:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .