2

Whenever I type l/ in terminal on OS X (Mavericks), it replaces it with a blank space. I can't seem to find any relevant problems or fixes on Google and I have no idea why this happens.

For example, if I want to type:

cd Documents/clinical/

It would do:

cd Documents/clinica 

I have tried tab completion and it just does the same thing. This also occurs in ZSH.

I have tried this though, using test folder names:

mkdir clinical
cd clinica (automatically turns clinical/ into clinica  )
mkdir specl
cd
cd clinica  spec  (it's turning the l/ into whitespaces for clincal/ and specl/ )

…and it does put me in the directory of /clinical/specl/.

So I'm really not sure how to get around it … it's kind of frustrating.

Any advice?


$ stty -a
speed 9600 baud; 32 rows; 120 columns;
lflags: icanon isig iexten echo echoe -echok echoke -echonl echoctl
    -echoprt -altwerase -noflsh -tostop -flusho pendin -nokerninfo
    -extproc
iflags: -istrip icrnl -inlcr -igncr ixon -ixoff ixany imaxbel iutf8
    -ignbrk brkint -inpck -ignpar -parmrk
oflags: opost onlcr -oxtabs -onocr -onlret
cflags: cread cs8 -parenb -parodd hupcl -clocal -cstopb -crtscts -dsrflow
    -dtrflow -mdmbuf
cchars: discard = ^O; dsusp = ^Y; eof = ^D; eol = <undef>;
    eol2 = <undef>; erase = ^?; intr = ^C; kill = ^U; lnext = ^V;
    min = 1; quit = ^\; reprint = ^R; start = ^Q; status = ^T;
    stop = ^S; susp = ^Z; time = 0; werase = ^W;
  • What happens if you try this with a different user account on your Mac (log in via Finder/OSX, not via Terminal)? – nohillside Jan 1 '14 at 10:13
  • You might have an error introduced in your tty special characters. Could you add the output of the following command to your OQ: stty -a? – dan Jan 1 '14 at 22:10
  • → Caleb: thank you. My hypothesis of an error within your tty special characters was wrong. – dan Jan 2 '14 at 11:05
  • → Caleb: within Terminal open Terminal > Preferences… > Settings > Keyboard and look at the Key column to see if you didn't inadvertantly introduced a binding for the "l" or "/" character. – dan Jan 2 '14 at 11:10
  • Hi daniel: I've looked at the Keyboard and there is no binding for the "l" or "/" characters. P.s. Sorry for late reply (was in hospital :/) – Caleb Fetzer Jan 7 '14 at 6:22

You must log in to answer this question.

Browse other questions tagged .