13

I am trying to move a large (100GB+) folder from the Desktop into a subfolder on the Desktop. When I drag and drop, it invokes a copy, and I do not want to wait an hour while it goes through with this (I will need to do several such moves.) I have read that holding CMD while drag-dropping will invoke move, but it does not. If I wait for a folder to finish the alleged "move" operation, it turns out to be a copy, with the original folder left behind.

Interestingly, if I attempt to move (drag/drop) a smaller folder, it does so without issue. What am I doing wrong?

  • If the folder's contents are large then it is going to take time checking what needs to process. I suspect @MJWalsh's answer is what is actually happing. If you do have some odd permissions on the folder and its contents that make it copy (doubtful that you do ) then try and move one of the files inside the folder to the new folder. If that works then again the Title is most likely what is confusing you with the move action. – markhunte Jan 1 '14 at 14:49
  • This question (apple.stackexchange.com/questions/111292/…) appears to be related. OSX was certainly trying to perform a copy, even after all of the files in the folder were enumerated. I managed to work around this by going into the folder, CMD + A (select all), then drag-dropping the folder contents directly into another folder. This was instant. – Bigbio2002 Jan 2 '14 at 22:02
14

Open your terminal (Terminal.app)

Then do:

mv source_folder destination_folder

e.g:

mv /Users/foo/Music/ /Users/foo/something

This is way faster than copying as it maintains inode

  • this moves the Music folder inside something. how to move the contents of Music to something? – lawphotog Sep 15 at 21:15
10

You can use option + command + V for moving a file or folder to destination folder after copy it using command + C.

  • This is a very, very good option. I'm surprised I never knew about it. I hope OP read it. – jared Mar 5 '16 at 19:13
5

If you are comfortable using /Applications/Utilities/Terminal.app, you can use the mv command.

mv <source folder> <destination folder>

To make typing simpler, type mv (with a space after) then drag the folder icon of the source folder into the Terminal window, then drag the folder icon of the destination into the Terminal window. This will construct the correct paths to the folders, including escaping space characters should they exist in the folder names.

This operation works in the background so you can get on with other things, and can be quite speedy as it doesn't rely on the Finder. I've found this method the best for transferring (copying cp or moving mv) hundreds of thousands, or even millions, of files, which the Finder can choke on. I suggest you do a few tests to make sure you get the hang of it.

  • This stuff about dragging folders into the Terminal windows was very helpful! Thank you! – Tim Elhajj Oct 8 '14 at 14:39
4

Drag/drop should move and not copy the folder. Normally Mac only defaults to copying if you're moving something to a different volume, such as a USB mass storage device.

Are you sure you're not misreading the move window it's titled "Copy" even when it's moving files.

Macosx copy winodw

  • That's a copy, not a move... A true "move" would not duplicate the data. – Bigbio2002 Jan 2 '14 at 22:00
2

This question appears to be related, it seems to be a permissions issue. I worked around this by creating a new folder at my destination and moving the folder contents into that new folder, instead of trying to directly move the folder itself. This invoked a proper Move operation without any special commands or key combos, and the files were moved instantaneously.

1

This threw me as well after installing mavericks. It's some kind of authorization/permissions thing … dragging folders from the root HD to the Desktop always resulted in a copy, regardless of command or option keys.
In my case fixed by doing a Get Info on the HD and Desktop , and changing the folder permissions to Read/Write.

1

Simply hold down the "Command" key while dragging a file or folder to enable the "Move" action as opposed to the default "Copy" action in OS X Mavericks.

-1

Check the file permissions for the source folder before moving.Change it to read & write mode.It will work

  • 1
    Are you sure about the need for checking permissions on the source folder? – nohillside Apr 7 '14 at 11:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .