I haven't been installing anything on my iPad Mini for the past few weeks. But previously, I just had to tap on "Install", enter my Apple ID password and go.

Now, for every new application, even those free ones, I have to confirm each time, that I'm 17 or over. And then App Store asks to enter my credit card information. If I disagree and hit "Cancel", installation process is interrupted and I can't install any application, even free one.

I don't trust Apple at all and I'm not willing to share my credit card information, especially that I'm installing only free applications.

I'm pretty sure that I haven't changed anything in the configuration of my iPad Mini for ages.

Am I missing some significant change to the App Store or this is some kind of bug or virus? Is there anything I can do in this situation? How can I install a free application from the App Store, without having to share my credit card information with Apple?


You need to select that you don't have/want a payment option.

  1. Open SettingsiTunes & App Stores
  2. Tap View Apple IDPayment Information
  3. Select None as the payment type

If you're not able to select None or the None option is not present for you to select, there are some possible reasons as to why this is the case:

  • Unpaid balance
  • Changed country/region
  • Family Sharing management

For more information, see the Apple KB article:

If you want to create a new Apple ID with None as the payment method, purchase a free app from the App Store and choose Create Apple ID. For more information, see:

| improve this answer | |
  • Thank you for your help. This does solve my problem. However, your answer does not explain, why do I have to change these settings? I haven't changed this before ever. Has something changed in iOS? Why it suddenly started to require payment information without any change from my side? – trejder Dec 31 '13 at 16:12
  • 1
    @trejder I'm not sure either — I did this once when I created one of my Apple IDs and have never had to do it again, so I'm not sure why it switched seemingly randomly. – grg Dec 31 '13 at 16:15
  • Where is this Settings -> iTunes & App Stores to be found? I've checked in System Settings, but such an option is missing. – user569825 Jan 20 '14 at 13:11
  • @user569825 Settings.app on your iOS device → iTunes & App Stores – grg Jan 20 '14 at 16:23
  • 1
    @Pepijn Yes — go to iTunes → Account → Payment and select None. – grg Mar 1 '14 at 16:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .