3

So the device in concern is the iPhone 3S. It has been jailbroken in the past and I haven't really used it since. And now I decided to upgrade it so I restore it to factory settings, except there is a critical issue. The device claims that there is no SIM card inserted into it. I tried with multiple SIM cards and bought a new one too, just in case, and the phone continues to give the same message. I am locked in the screen in which the iPhone is to be connected to iTunes. For Apple servicing, I need the index number, for which I need to start the phone and go to Settings, but this phone is completely locked. I tried re-inserting the SIM many times but there seems to be no change. So far I have done the following:

  • Determine the language
  • Country of usage
  • Choose a WiFi network/ connect to iTunes. And that's all.

This question is similar to one asked before, but I have tried the tape as well and it lead nowhere. And I don't have an AT&T SIM.

iPhone stuck at "No SIM card installed"

1

No one has responded, and with the information you've given, it is difficult to know exactly. But I would guess that while jailbroken, the device was also unlocked, and when you restored factory settings, you lost the unlock, and now the iPhone is once again locked and expecting an AT&T SIM. If you can acquire an AT&T SIM, and it works, then this will be confirmed.

However, this is a rather common issue with a very simple solution, and perhaps my hypothesis is wrong.

Sorry it took so long for a suggested solution!

And Happy New Year!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .