127

I want to unset the Cmd+M shortcut but I can't seem to find it. I've checked System Preferences > Keyboard > Shortcuts but no luck there. I've even tried running defaults write -g NSUserKeyEquivalents -dict-add 'Minimize' '\0' to no avail.

2
  • 9
    I totally hate this useless shorcut
    – Nikos
    Dec 29, 2021 at 12:32
  • Did you maybe not restart before checking that defaults write -g NSUserKeyEquivalents -dict-add 'Minimize' '\0' doesn't work? It did the job for me and worked just fine out of the box (after applications were restarted). Jan 26, 2023 at 14:16

8 Answers 8

151

You don't need to install any additional software.

  1. Go to System Preferences > Keyboard > Shortcuts > App Shortcuts

  2. Click the Plus Button button below

  3. Enter "Minimize" (use "Minimize All" to override minimizing all windows with ⌥⌘M) into the Menu Title text input field.

  4. Assign some bizzare key combination that you won't press by accident.

  5. Repeat steps three and four for "Minimise" (alternate spelling) which is required for some apps.

  6. Close the window to save the changes.

Keyboard Shortcuts Settings

I'm aware that this is not really "disabling it" but the result is effectively the same and without depending on 3rd party software.

15
  • 8
    This didn't work for me on El Capitan 10.11.2. "Minimize" shows up under "All Applications" in the Keyboard Shortcuts list, assigned to Control-Option-Command-M, but that key combination doesn't minimize, and Command-M still does. Jan 20, 2016 at 19:36
  • 4
    Yayyyy! Thank you. This is a constant annoyance as it always happens when I accidentally hit Command+M, and I NEVER want to do it on purpose. I finally decided to take a few moments to Google a solution, and yours fixed the issue. Sep 20, 2018 at 14:23
  • 2
    THANK YOU! Worked on Monterey 12.1. any way to tip you for the end of this annoyance? would love to leave you a tip...
    – Mike
    Jan 29, 2022 at 15:40
  • 3
    this does work for me on Monterey, but as I'm in the uk locale, the menu item was "Minimise" with an s. if others have problems with this, make sure the spelling is correct for your locale
    – stevel
    Apr 21, 2022 at 12:48
  • 4
    such a dumb feature by apple Jul 21, 2022 at 14:03
15

Alternative Solution

I tried to follow setting my own shortcut like Machal has suggested. However it didn't work for me and just doubled the keybinding for minimize.

I did find, that setting something else to CMD+M worked perfectly:

enter image description here

6
  • Interesting, but also doesn't seem to work. The problem is that this merely overrides the command-m. If you disable the selection here, then command-m will still cause the window to minimize. I (and presumably others) want to do this so that they can use the command-m for other applications.
    – SMBiggs
    May 15, 2015 at 17:46
  • 1
    This worked for me on El Capitan 10.11.2 Jan 20, 2016 at 19:38
  • Also works for me in macOS Sierra Sep 28, 2016 at 20:10
  • 1
    Confirmed to also work in Catalina. I set my Cmd+M to "Paste" under App Shortcuts > All Applications. This bugs the hell outta me, specially when connected to a second monitor :( May 28, 2020 at 10:08
  • Still minimises the window on MC Jul 21, 2022 at 14:06
13

macOS 10.12 (Sierra):

The accepted answer didn't work for me. But setting the CMD-M mapping to a different action worked right away:

  1. Go to System Preferences > Keyboard > Shortcuts > App Shortcuts

  2. Check off the Show Help Menu item and

  3. assign it a CMD-M key combination.

Keyboard Shortcuts Settings

Not a perfect solution, but still much better than minimizing the window accidentally.

7

macOS 13.2 (Ventura):

  1. Go to System Settings... > Keyboard > Keyboard Shortcuts... > App Shortcuts

  2. Add all following shortcuts with different bindings under All Applications (use small + button under bindings table):

    • Minimise = Cmd + Ctrl + Opt + Shift + 9
    • Minimize = Cmd + Ctrl + Opt + Shift + 8
    • Minimise All = Cmd + Ctrl + Opt + Shift + 7
    • Minimize All = Cmd + Ctrl + Opt + Shift + 6
    • <Your Localised Names for these commands> = Cmd + Ctrl + Opt + Shift + 5, 4, ...
  3. Switch from System Settings... to any other application (Cmd + Tab)

  4. Go to Menu bar > Window > check new shortcuts are in effect

Profit!

macOS 12.5 (Monterey):

  1. Go to System Preferences > Keyboard > Shortcuts > App Shortcuts

  2. Add all following shortcuts with different bindings under All Applications:

    • Minimise = Cmd + Ctrl + Opt + Shift + 9
    • Minimize = Cmd + Ctrl + Opt + Shift + 8
    • Minimise All = Cmd + Ctrl + Opt + Shift + 7
    • Minimize All = Cmd + Ctrl + Opt + Shift + 6
    • <Your Localised Names for these commands> = Cmd + Ctrl + Opt + Shift + 5, 4, ...
  3. Switch from System Preferences to any other application (Cmd + Tab)

  4. Go to Menu bar > Window > check new shortcuts are in effect

Profit!

macOS 10.16 (Catalina):

  1. Go to System Preferences > Keyboard > Shortcuts > Accessibility

  2. Enable Invert colors shortcut

  3. Assign Command + M combination

  4. Disable Invert colors shortcut

Profit!

4
  • Does not work for me. Ah well. Loss!
    – phatmann
    Oct 17, 2021 at 11:55
  • 1
    Oh my gosh. I tried every other answers above but fails. This one is the only one that works. Thank you @ursa !
    – Roeniss
    Sep 8, 2022 at 10:50
  • you're welcome. I've also updated this guide with settings I use for Monteray. hope it helps =)
    – ursa
    Sep 8, 2022 at 16:16
  • I had to add "Minimize Window" for Arc browser, but then I realized that "Minimize Window" is built-in hotkey to arc and I just disabled it there. Jul 30, 2023 at 16:51
4

In 2023 on macOS 13.2, the answer suggested here: https://apple.stackexchange.com/a/73957/330523 worked perfectly - and it's much easier to script so that you don't loose the setting if you move to a new machine:

defaults write -g NSUserKeyEquivalents -dict-add 'Minimize' '\0'

Remember that the change only applies to applications that have been reopened (or after system restart). Maybe that is why it didn't work for you?

3
  • 2
    It seems some applications do not honour it, such as Firefox Mar 8, 2023 at 14:08
  • 1
    @CiprianTomoiagă you are right - now that you mention it, it doesn't work on quite a few application either. Maybe I never tested it enough? Strange. Mar 8, 2023 at 15:30
  • Remember to also register Minimise (British spelling). Also some apps (e.g. IntelliJ) have their own keyboard shortcut handling which also needs configuring. Such a mess.
    – Tamlyn
    Oct 16, 2023 at 9:11
3

Using Karabiner, this works with High Sierra and higher.

Make a file something like this in ~/.config/karabiner/assets/complex_modifications/emacs_shortcuts.json

{
  "title": "Emacs",
  "rules": [
    {
      "description": "Emacs Shortcuts",
      "manipulators": [
        {
          "from": {
            "key_code": "m",
            "modifiers": { "mandatory": ["command"] }
          },
          "to": [{
            "key_code": "m",
            "modifiers": ["left_command", "left_shift", "left_control"]
          }],
          "type": "basic"
        }
      ]
    }
  ]
}

Then go to Karabiner and activate it.

1

The easiest way to do this is to install a key remapper (I use KeyRemap4MacBook). Though the name seems to suggest otherwise, currently KeyRemap4MacBook actually works with all Apple computer products that can run OS X 10.4 or later, including iMac, Mac mini, and Mac Pro.

Using this method, you can map ⌘M, which OS X maps to the minimize function by default, to Fn+⌘M, which is significantly harder to accidentally press, and which OS X maps to no functionality by default.

In other words, you can swap the functionality of these two key combinations so that ⌘M no longer has a functionality and is essentially disabled. While it is not strictly "disabling" the shortcut, this workaround achieves the same effect.

Use the following steps to disable the minimize shortcut in Mavericks:

1. Install KeyRemap4MacBook

Download the appropriate .DMG file from the link above and double click it. If you get a message like this:

Your security preferences allow installation of only apps from the Mac App Store and identified developers

Then open the System Preferences program already installed on your computer and, under the Personal tab, select Security & Privacy. Next, under the General tab, click the lock in the lower left corner to make changes (provide an administrative password if needed), and under Allow applications downloaded from: label, select the Anywhere radio button.

Now you can install the application; you may need to restart once it's finished.

2. Configuring the custom settings

While KeyRemap4MacBook offers a diverse collection of useful features, disabling the minimize shortcut is not among them. Instead, it provides a handy XML file that you can modify using their API to achieve almost any key remapping you can think of.

Open KeyRemap4MacBook, and navigate to the Misc & Uninstall tab. Under the Custom Setting label, click the Open private.xml button. Make sure the document opens in a plain-text editor such as TextEdit. Once opened, you should see a blank XML file with empty root tags. Replace the entirety of its contents with the following code snippet:

<?xml version="1.0"?>
<root>
    <item>
        <name>Disable Minimize</name>
        <identifier>private.disable_minimize</identifier>
        <autogen>
            __KeyToKey__
            KeyCode::M, ModifierFlag::COMMAND_L,
            KeyCode::M, ModifierFlag::COMMAND_L | ModifierFlag::FN
        </autogen>
        <autogen>
            __KeyToKey__
            KeyCode::M, ModifierFlag::COMMAND_L | ModifierFlag::FN,
            KeyCode::M, ModifierFlag::COMMAND_L
        </autogen>
    </item>
</root>

[Note: The previous code uses the left-most command key. If you are interested in disabling the right-most command key, change each instance of COMMAND_L with COMMAND_R.]

Save the private.xml file. Return to the Change key tab. In the main list, under the remapping label, you should now see a Disable Minimize checkbox.

Check the checkbox, and you should now no longer be able to minimize your windows with the ⌘M shortcut. If you ever need to use the shortcut again, use Fn+⌘M, or simply uncheck the Disable Minimize checkbox.

0

I disabled Mission Control in "System Pref>Shortcuts Tab>Mission Control" by unchecking checkbox Mission Control in the column and then Cmd-M would minimize any app open instead.

So, using "Keyboard Maestro" I creating a "Do Nothing" Group and assigned Cmd-M to "No Action" as in screenshot. Worked like a charm!

1
  • 3
    Which screenshot are you referring to?
    – nohillside
    Jan 17, 2016 at 11:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .