3

Recently (as in today) I noticed that Finder had some missing icons in the toolbar. I also noticed that Xcode 5 has some missing icons as well. I have included an image of the Finder issue here.

I am running 10.9.1 (Most current version of Mavericks).

Any ideas on a cause?

Finder with Missing Icons

2
+100

Not entirely sure what the cause is, but this fixes it for me:

  1. Boot into safe mode by holding shift on boot.
  2. Login to your account.
  3. Restart normally.

There appears to be some sort of caching error and this mechanism also is susceptible to the same fault on older OS as well.


From an Apple Support Communities thread, it seems that it can be fixed for some people by deleting the Dock's Application Support files.

rm ~/Library/Application\ Support/Dock/*.db && killall -HUP Finder Dock
  • Unfortunately this did not fix the problem for me. – dtuckernet Jan 2 '14 at 19:20
  • Have you tried repairing permissions? Also, are there any "interesting" console logs when you start your computer? – David DelMonte Jan 2 '14 at 19:58
  • I found that this is not uncommon. Someone on Apple Support Forum posted this: "1. Open 'Terminal'; 2. Copy this text (without commas): '' mv ~/L*/Application\ Support/Dock/*.db ~/Desktop "; 3. Press Enter; (Screen will flash and icons, dock & finder will disapear for some seconds! In the end, everything will appear on screen!" – David DelMonte Jan 2 '14 at 20:04
  • 1
    So - this fix ultimately did work. However, I didn't realize that it wasn't really logging into Safe Mode. I had to disable FileVault 2 before I could get into safe mode. – dtuckernet Jan 2 '14 at 21:35
0
  • 1. answer

This answer was taken from here. The person seemed to experience the same problem under OS X Mountain Lion (10.8.3). Maybe these steps will do the trick for you, too.

Please read this whole message before doing anything.

This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, or by a peripheral device.

Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.

Safe mode is much slower to boot and run than normal, and some things won’t work at all, including Wi-Fi on certain iMacs. The next normal boot may also be somewhat slow.

The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

Test while in safe mode. Same problem?

After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • 2. answer

Another person who experienced a more complex problem incl yours. The entire thread can be found here. But the problem was solved like this:

  1. I downloaded Mountain Lion from Apple Store (yesterday).
  2. Today I executed the Installation File form Launchpad.
  3. The installation executed perfectly and now everything is working again.
  4. Everything: Missing Icons, Spotlight ... is now perfect!

Maybe this helps, too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .