I've just recently changed the ISP and now have a cable modem, which only has one LAN port. Connecting here requires to use DHCP to get an IP address. Connecting my laptop works just fine and I get an IP immediately.

When I connect my AirPort Extreme to this port instead (with the intension to get the IP address assigned to it), while configuring it to share this public IP, it will not get an IP from the cable modem. It stays on 169.xxx.xxx.xxx and nothing happens. I have tried many different settings to just see if the router can get an IP from the cable modem using DHCP. No success.

Internally over wireless I can connect all my devices and they get IPs assigned by the AirPort Extreme DHCP, so this works fine.

At this point I don't know what might be the problem, but my guess is that the AirPort Extreme has some problem. I googled a bit, but found nothing that would solve this, so I thought someone might know here.

Thanks in advance!

  • 1
    You might try to reset the cable modem (by unplugging the power). If it is only willing to provide DHCP for a single host, it may not give an address to the Airport while still remembering your laptop. Apr 7, 2011 at 13:57
  • @Harald: I'm almost embarrassed to admit I didn't try this and this actually solved things. Thanks for reminding me about something simple! :) If you make it an answer I'll accept it for you.
    – murrekatt
    Apr 7, 2011 at 15:26

1 Answer 1


Many cable modems will only provide DHCP for a small number of hosts, possibly only one. Resetting the modem by unplugging its power supply should let it forget what hosts it has provided IP addresses for, so you can start over.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .