5

After upgrading from ML to Mavericks (MB Air, 13", 256GB, 2011) I can't open any file or folder from the standard Open menu from any app (except MS Office -2011). But, I can search for a file (and open it) if it has a label. All the files/folders are greyed out so can't select them, as it can be seen in the attached screen capture (from Preview.app).

If I try to save a file, the only place I can do that is in the default folder: if I try to change the folder (navigating through the Save box) I can't save it any more.

What I've done (nothing worked!):

  1. repairing permissions
  2. delete and create a new user (keeping the user folder in /Users)
  3. updated to 10.9.1

It is worth to point out that this only happens in my user account: after discovering this situation I created a second admin user and everything works fine within it!

This is a screenshot of the Open menu.

  • Can you add your solution as an answer below and accept it? This will make it easier for others to find it later. – nohillside May 21 '14 at 10:55
  • You need to reset your Home Folder Permissions and ACLS in Reccovery Mode for the specified user account: pondini.org/OSX/Password.html – njboot May 21 '14 at 10:59
0

Maybe you could start by moving ~/Library/Preferences/com.apple.finder.plist (where ~ is you're home folder) to the desktop and restart the Finder by typing sudo killall Finder into terminal. If it works with another user, it may be something in you're Library folder that is causing the problem. I would also check you're startup items under System Preferences:Users:Login Items. Another thing that could help is check you're logs in the Console Application and see if it is reporting anything unusual there.

  • Thank you, but I solved this… by re-installing the SO… – F_Jofre_A May 21 '14 at 10:47
  • Did you actually solve the problem or did you just delete the problem by reinstalling you're OS. Thanks for the vote down for trying to help. – James Payne May 22 '14 at 11:29
  • I didn't vote down you! I am not such an a..h..le to do that to someone who's trying to help me! – F_Jofre_A May 22 '14 at 16:08
  • Oh ok no worries. Somebody else must have. Just as a matter of interest, this actually happened to me once where I had bound my OSX account to a OS X OD server. To get my files back, I just unbound from the directory. Does that sound familiar? – James Payne May 23 '14 at 7:20
  • Not at all! I just updated from 10.8.X to 10.9. And that was all! – F_Jofre_A May 25 '14 at 20:31
0

As James Payne stated, I did not solve the problem, instead I deleted it by re installing the SO. I couldn't try the solution proposed by njboot because I did it before his/her suggestion.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .