9

I use WordPress keyboard shortcuts a lot, but Safari's use of Cmd + [Num] (e.g. 1, 2, 3) is overriding WordPress' use (which formats text with tags).

How can I disable Safari's use of the keyboard shortcut so that I can use it for WordPress?

5

The shortcuts are defined as the first few bookmarks in your Bookmarks Bar. You can see which bookmarks are defined by going to Bookmarks → Favorites Bar. Since they are menu items, you can disable them by remapping them to something else.

  1. Open System Preferences → Keyboard → App Shortcuts.

  2. Click the + to add a new shortcut.

  3. Set the Application to Safari, the Menu Title to the exact name of one of your bookmarks, and the Keyboard Shortcut to something other than ⌘#.

  4. Repeat the process for the other bookmarks.

  • Fantastic, thank you! What if I don't have any bookmarks in the favorites bar? – Tom Dec 28 '13 at 15:11
  • @Tom Then the keyboard shortcut should work fine without any need to remap it. – grg Dec 28 '13 at 15:15
  • Also, this doesn't seem to be working regardless...presumably because the Menu Title is not being set correctly, despite me duplicating the bookmark names. – Tom Dec 28 '13 at 15:16
  • @Tom Are you writing the bookmark title as it is shown in the list at Bookmarks → Favorites Bar? (example) – grg Dec 28 '13 at 15:17
  • 3
    This adds a new shortcut for that entry, but doesn't seem to remove the old old. So both Cmd-1 and Shift-Cmd-1 now opens the first favorite. (Very bad behavior on Safari's part; shortcuts should always exactly match to menu items.) – Rob Napier Apr 10 '14 at 13:04
0

i had the same issue, my stupid fingers type CMD+2 instead of ALT+2, i notice that bookmarks automatically assigns this option and you can't disable it, BUT! the only way is to delete roots, on your favorite, the direct link is assigned to CMD+#, but if your favorite is inside a folder it doesn't get a #, so, you need to MOVE your direct shortcuts to a folder, then you'll lose the shortcut of evil! THAT RESOLVE MY ISSUE!!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .