1

I recently got an old iBook G4 (as many of you might have noticed with all of my recent questions :D) and I wanted to install Ubuntu via USB (the iso doesn't fit on a CD and the iBook doesn't read DVDs, I've tried).

So I went a-searching the internet for ways to do this.

I started off trying to boot from the USB stick via holding down option after the chime, but that just listed the Macintosh HD. So I went on searching and came across this: http://ben-collins.blogspot.com/2010/08/booting-your-ibook-g4-from-usb-stick.html and tried it multiple times, but all failed (I believe the iBook wasn't recognizing the USB stick, as nothing came up when I ran dev usb0 and then ls.)

I then read this question: How do I make my 1.5 GHz PowerBook G4 boot from a USB stick?, but that didn't work, even when I swapped out the suffix \\yaboot for \\tdxi. Sadly, nothing is working!

Does anyone know of any workarounds or something I can do to get this working?

2

I know this old, but I just solved this problem, and I had found this question while searching for an answer.

In my case, 2005 iBook wouldn't recognise the 10.5 install DVD. I imaged the DVD to an 8GB usb stick in Disk Utility. I did format the USB stick as Apple Partition Map first in case that makes a difference.

It wouldn't boot from the USB when holding down option or C though I could get a menu.

I booted to open firmware by booting with command+option+O+F then I ran the following command: boot usb0/disk@1:3,\\:tbxi

It booted into the installer and everything worked as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .