Windows 8.1 isn't playing back audio on my 13" mid-2012 Macbook Pro. I only have a speaker with an x on my notifications bar. When I click on it, I get the usual "detecting problems" garbage. Unfortunately, every "solution" I've found seems to work for everyone else, but not for me.


Device Manager

Windows shows a High Definition Audio Controller listed under System. Its properties state that it has a Code 10 - "This device cannot start", along with "The requested operation was unsuccessful." This is the only notion of an audio device listed in Device Manager.

Most solutions I've found say drivers need to be reinstalled (downloaded from the internet or simpliy re-run from the Bootcamp support drivers) and I've currently tried the following:

  • Bootcamp setup.exe (No errors are reported, 5.0.5033 "installs" a variety of sound drivers)
  • Cirrus Audio (Both CirrusAudiox64.exe and a manual .inf installation)
  • Realtek (I've tried nearly every link I've found)
  • Intel Graphics 4000 (apparently it does audio too)

Every executable runs and reports success, however, I don't see any sign of a change apart from the Realtek driver copying files somewhere in Program Files, and the Intel driver blanking the screen a few times.


Cirrus Audio

I've tried manually installing the Cirrus Audio driver by performing the following:

  1. Select High Definition Audio Controller from Device Manager
  2. Click on Driver -> Update Driver
  3. Select "Browse my computer for driver "
  4. Select "Let me pick from a list of device drivers"
  5. Click "Have Disk..." and navigate to the .inf file

At this point windows complains that the driver does not support Windows x64, despite having "x64" written all over it.

"The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems."

If I skip #'s 4 and 5, and browse directly for the driver files, Windows reports that the Driver software is already up to date.

"Windows has determined the driver software for your device is up to date."

This makes me believe that Windows 8.1 might have an issue with certain drivers, deeming them unusable in some way. It's possible that windows is denying the .exe installers' drivers, Realtek, and Cirrus behind the scenes, without letting them install anything. Maybe they report success and silently fail?


Setup

It's worth mentioning that my Bootcamp setup isn't typical. I've partitioned the hard drive and installed windows manually, alongside Arch Linux. (I've triple booted this thing, and windows audio is the final hurdle.) I'm also using the refind efi bootloader to boot the system.

For the windows boot option, I point refind to /EFI/Microsoft/bootmgfw.efi, without any options. I'm thinking that Bootcamp might do more than partition and install, and that I'm supposed to do more to inform windows about the macbook hardware at this stage. Is this the case? Did I miss something critical about Bootcamp?


If anyone can help me solve this, I will be eternally grateful. Thanks.

P.S. I'm a linux user, so windows drivers aren't exactly my forte. If I'm doing something totally wrong, please let me know.

  • Bootcamp 5.0.33 is from Mountain Lion. What version of OS X are you using? EFI issues for various hardware components have many discussions on Apple forums, that you may want to check. Mavericks has Bootcamp 5.1.0 (473) which may help with newer drivers. I have 13-in MBP 2012 running Windows 8.1 (using Bootcamp) and sound works properly. – user63628 Dec 27 '13 at 0:17
  • I should also mention that I am using BIOS rather than EFI. – user63628 Dec 27 '13 at 0:36
  • Ah, I lied, it was version 5.0.5033. Either way, I can't find 5.1.0 here – lowq Dec 27 '13 at 4:05
  • I checked the bootcamp.inf file and the header still says 5.0.5033, so you may already have the latest version. – user63628 Dec 28 '13 at 17:51
  • You need a version of bootcamp drivers that support Windows 8.1 – Thorbjørn Ravn Andersen Jan 1 '14 at 2:01
up vote 3 down vote accepted

Navigate on your Mac to the Bootcamp application. Before this make sure you have a 8GB USB flashdrive formatted to FAT 32, Windows default. Open Bootcamp app, and install the latest Bootcamp drivers onto the USB. I suggest naming the USB to SUPPORT all caps after doing this.

Navigate to Windows Partition on boot menu. Open up File Explorer, click on you new SUPPORT drive, open up Bootcamp folder, then drivers, click on Realtek driver set up .exe, and install that (depending on your computer it will prompt you to restart it or not after installing). Next after rebooting or re-installing the Realtek driver, head into the Cirrus folder.

This is the most important part about getting the sound to work

Click on the second .exe driver manual download, and run it. If you don't do the second one first, it won't work. After the download is complete, click on the first Cirrussetup.exe and install that. After that is complete, when you go to test your Mac's sound, there will be a slight delay... followed by the nice obnoxious chirp on Microsoft's sound test.

Sound working on Windows 8.1 x64 at 10:50, 2/21/2015

  • This worked on a MacBook on Windows 10 when the accepted answer did not. – jejorda2 Nov 25 '15 at 0:37
  • I recall installing driver after driver, but I didn't use Bootcamp to partition when I was having sound problems. You state that you have a Bootcamp partition, which tells me you did. I'm skeptical that .exe run order causes the BIOS to label hardware differently. Marking accepted, but I don't plan on testing this anytime soon. If you triple booted and had sound, congrats! FWIW, a year ago I dropped windows and now boot OSX and Linux instead ;) – lowq Dec 13 '17 at 5:43

Forget EFI and install using boot camp assistant.

After backing everything up, wiping my partitions, and installing Windows 8.1 using Bootcamp, everything works as normal. The machine boots using bios mode, Cirrus Audio was properly installed after a single run of setup.exe from the Bootcamp support software, and the device is recognized properly as VEN_1013 DEV_4206 --Cirrus Audio CS4206B (AB 82).

It sucks, but it's worth it. I plan on resizing windows' ntfs partition and booting linux beside it, but that's a problem for another day.

  • Please be careful with Bootcamp partition resizing. It causes problems. See this link - support.apple.com/kb/HT5639. You may end up reinstalling Windows from scratch in BIOS mode. – user63628 Jan 1 '14 at 22:20
  • Thanks for posting this; Now I have sound :) Btw I did try several other "solutions" first, with no luck... So what I just did was I pluged my bootable usb drive (from bootcamp) back in and went into bootcamp>drivers>Cirrus then clicked the exe and it auto changed the drivers and enabled my microphone as well. hope this helps! – user113068 Feb 9 '15 at 18:33
  • I really hate to admit it, but after trying a gzillion options over 8 hours of heart-aches, I had to re-install Windows 10 in Legacy mode to get it working. I have a Macbook Pro Mid 2012 model and formatting Windows and installing it again in Legacy mode (not UEFI / EFI) immediately fixed the sound issue - without even having to install the BootCamp drivers. – saurabhj Aug 25 '16 at 4:35
  • Downvoted because OP has said they need to triple boot, which is impossible to accomplish with the hybrid MBR scheme. Hybrid MBR is incompatible with the MBR extended partition, limiting you to 4 partitions. EFI protective + Mac + Mac recovery + Windows + Linux = 5 partitions. – mm201 Dec 12 '17 at 15:45

So what I just did was I pluged my bootable usb drive (from bootcamp) back in and went into bootcamp>drivers>Cirrus then clicked the exe and it auto changed the drivers and enabled my microphone as well. hope this helps!

If you installing Windows 7/8/8.1 on MAC in EFI (native) mode - you'll get problem with sound. If you installing Windows in BootCamp mode - you'll get corrupted files on your hybrid MBR/GPT disc if you'll try to use same files on both systems. If you have only 1 system (Windows in bios mode or Mac OS in gpt) - no problem. So you have to decide.

protected by Community Apr 5 '15 at 21:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.