0

I have 4 samba shares on a Synology DiskStation that I successsfully automount on my 10.9 / Mavericks based system under /Shares/ and when I open the command line I can go there just fine and list the files and directories just fine, however when trying to navigate to /Shares via the Mac OS X finder, the directory just seems entirely empty:

Screenshot

My /etc/auto_master looks like this:

#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static
/Shares         auto_smb    -nosuid

... my /etc/auto_smb like this:

home -fstype=smbfs,rw,soft ://joerg:myPassword@nasHostname/home
Downloads -fstype=smbfs,rw,soft ://joerg:myPassword@nasHostname/Downloads
Music -fstype=smbfs,rw,soft ://joerg:myPassword@nasHostname/Music
Videos -fstype=smbfs,rw,soft ://joerg:myPassword@nasHostname/Videos

What am I missing here? Why aren't the shares displayed in Finder?

2
  • What happens if you type "Shift-Cmd-G" in Finder and enter /Shares/Music directly?
    – nohillside
    Dec 26, 2013 at 12:28
  • @patrix: tried that and forgot to mention above - it does open the folder and displays/lists the content perfectly fine. Dec 26, 2013 at 12:31

1 Answer 1

1

Perhaps the 'hidefromfinder' option in your auto_master setup file has something to do with it?

/net            -hosts      -nobrowse,**hidefromfinder**,nosuid
/home           auto_home   -nobrowse,**hidefromfinder**

From the auto_master(5) man page:

The hidefromfinder option is used on maps that shouldn't show up as folders in the Finder; it causes the UF_HIDDEN flag to be set on the root directory of the map.

1
  • It is not specified for the /Shares one(s).. so that shouldn't affect them (and these lines are Maverick default ones, so I wouldn't want to touch them). Dec 26, 2013 at 12:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .