2

How can it be that I cannot ping my own IP on Mac OS?

$ ifconfig -a
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128 
    inet 127.0.0.1 netmask 0xff000000 
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 
    nd6 options=1<PERFORMNUD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether b8:e8:56:46:d4:4e 
    inet 192.168.1.100 netmask 0xffffff00 broadcast 192.168.1.255
    media: autoselect
    status: active
en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 72:00:00:df:26:10 
    media: autoselect <full-duplex>
    status: inactive
en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 72:00:00:df:26:11 
    media: autoselect <full-duplex>
    status: inactive
bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether ba:e8:56:64:03:00 
    Configuration:
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en1 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 5 priority 0 path cost 0
    member: en2 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 6 priority 0 path cost 0
    media: <unknown type>
    status: inactive
p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 0a:e8:56:46:d4:4e 
    media: autoselect
    status: inactive

$ ping 192.168.1.100
PING 192.168.1.100 (192.168.1.100): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2

I disabled both the firewall on my Mac and on the wireless router which gives me the dynamic IP on en0.

  • Which IP address are you referring to? People do not have IP addresses, neither have computers, network interfaces do. – Carsten S Dec 26 '13 at 13:27
  • Please add a section to the question showing what syntax you are using to issue ping and what the tool says. – bmike Dec 26 '13 at 18:51
0

Your wireless card must not be configured to respond to ICMP requests.I haven't ever had this issue with actual ethernet cards, but instead with routers whos outside facing adapters would not respond to pings in the interest of security.

Can you ping your loopback (127.0.0.1)? My second question would be, are you running any software that would interfere with this (little snitch would be my first guess)?

Edit: Have you checked to see if "Stealth Mode" is enabled? I know you've turned your firewall off, but this setting however has exactly that effect.

  • This is a local address. The configuration of the wireless card has no effect on local traffic. – David Schwartz Dec 26 '13 at 8:10
  • So you're unable to ping 192.168.1.100? are you able to ping your loopback, as well as the gateway? – radiks32 Dec 26 '13 at 8:38
  • Yes, I can ping 127.0.0.1 and the gateway 192.168.1.1. I haven't installed little snitch and I disabled the firewall in System Preferences -> Security & Privacy -> Firewall. – tuxx Dec 26 '13 at 14:02
0

Looks like I had some firewall configurations set up by my company. So basically the firewall buttons in the GUI interface had no effect. This revealed the problem:

sudo pfctl -s all

Reinstalled the OS, overriding the presets, and problem solved. Thanks everyone.

  • I think I'm having a similar problem. How did pfctl reveal the problem? How do I interpret its output? – harithski May 18 '14 at 13:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .