The download in the App Store can't be installed, restarted, or deleted. This is for iMovie 10.0.1 as of December 23, 2013. I followed a discussion forum and tried a suggestion that said remove the application from finder. Unfortunately, this left me without the iMovie application and did nothing to change the status of iMovie from "downloaded". So, I can't even start over or resume. Is there a clean way to get out of this mess? The forums go on and on with various solutions and responses that say that one "...worked for me!".

My system software is OS X 10.9.1 running on a MacBook Pro Retina 15-inch, Early 2013.

2 Answers 2


To investigate the problem, please run Console to check the recent logs for more details (look for com.apple.installd).

In example, I had something like:

com.apple.launchd[1]: (com.apple.installd[69518]) Job appears to have crashed: Abort trap: 6
ReportCrash[69520]: Saved crash report for installd[69518] version 332 to /Library/Logs/DiagnosticReports/installd_2014*.crash

If you see the crash in your logs, then check the backtrace under System Diagnostic Reports, so there is something like:

Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSKeyedUnarchiver initForReadingWithData:]: incomprehensible archive

The reason for that could be that some of the downloaded files are corrupted.

So to solve that, you have to remove these files and try again.

Simple solution

  1. Quit your App Store
  2. Run Finder and go to (CMD+Shift+G): /private/var/folders.
  3. Trash all the folders from that folder (e.g. vp, zz).
  4. Run App Store and re-try.

In case something bad happens, restore these removed files from your Trash.

Advanced solution

From Terminal check if you've temporary files here:

ls -la /private/var/folders/*/*/*/com.apple.appstore

And then try to remove them (you may backup them first just in case):

rm -frv /private/var/folders/*/*/*/com.apple.appstore

Warning: Make sure you won't do any typos (like adding space between the folders), as you could remove the wrong files!

And re-try to run installer again.


  • 1
    Thank you so much. I have been suffering for a long time. Deleting files in /private/var/folders did the trick. iMovie is now being installed with no problems
    – Ahmad
    Commented Oct 21, 2014 at 0:04
  • 1
    The suffering was real. Glad I found this answer
    – omerio
    Commented Jan 3, 2016 at 15:23

Don't worry. If you can afford to be without iMovie for a couple of days, the App Store will eventually detect that it is not in your Applications folder, and you will be able to download it once more. I downloaded the free upgrade, but for my own reasons, I deleted it. At first, all that showed in the App Store was the word installed near to the name of the app. However, after a couple of days, I looked in the App Store, and once more, the download button was available. I downloaded it with no trouble, and in seconds!

  • Yes. I had a similar experience after deleting the iMovie 10.0.1 application. The exception was that the App Store downloaded iMove 10.0 first. Then a short while later, there was an update available which got me to iMovie 10.0.1. Commented Dec 28, 2013 at 17:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .