0

I'm talking about the services you find when right-clicking a file or folder.

It should be possible to 'remove' those services within the system preferences (under the keyboard section) but this just won't work for me. When I uncheck the services nothing happens and as soon as I reopen the system preferences window it's all back to default.

Maybe it's related to iCloud syncing (you know, those things Apple has yes to tell us about), but this is just a guess, nothing I know of.

  • 1
    Can you give an example which services you mean? Some are added by other Apps, so ti's a very general question IMO. – J.C. Dec 28 '14 at 9:30
1

I assume that you’re talking about the services added by third-party apps. You can do it easily by downloading Services Manager and turn off all the services you’re not using.

Services Manager for Mac

There are two options you may choose. Turning off context menu simply remove the services when you use secondary click on the files, images, or text, however, you can still run it from the  menu in menu bar.

Services Menu

0

Trash the preference file ~/Library/Preferences/com.apple.ServicesMenu.Services.plist, logout, login and try again with System Preferences. You may need to reveal the ~/Library folder.

  • Removing services in the system preferences window (as you said) did work for me. So maybe your plist is fouled up and should be removed as pietrodn says. – GEdgar Dec 25 '13 at 23:07
  • This did not work for me. I trashed the file (and the lock file as well) and restarted, but the problem persists. – Ben Dec 31 '13 at 11:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .