I recently bought a new SSD drive, as my stored data amounts outgrew the old one a little bit. After copying all data using dd if=/dev/disk0 of=/dev/disk1, I want to enlarge my system partition, but Disk Utility is failing silently and diskutil resizeVolume /dev/disk0s2 R (first partition is the EFI boot volume), I receive following error message:

Error: -5341: MediaKit reports partition (map) too small

How can I resize my system volume?


Your partition table does not know about the larger hard drive yet. While Disk Utility also queries the hard disk size and lets you request it to enlarge your partition, it will fail when finally changing the partition size (after doing a file system check).

This can be solved on different ways:

  1. One is to destroy the GPT (partition table) and recreate it manually, which is a rather annoying and error-prone way of fixing the problem as it's easy to mess up when adding your partitions again.

  2. An easier, better way is to run gparted, which is also included in current Ubuntu Desktop Live images (or is easy to install from their packages repositories) and probably lots of other Linux disks. After starting it, it will recognize the wrong disk size in your partition table and ask whether it should fix it for you. After fixing the table, reboot to OS X and finally enlarge the Volume.

  • GParted is excellent. It managed well a disk volume change (and partition map/filesystem resize) in my virtual machine.
    – pietrodn
    Dec 25 '13 at 21:30

I erased the drive and selected the scheme as GUID partition, tried setting up the partitions I wanted, hit apply and it worked. Then I erased the drive again, selected Apply Partition map (which was previously giving the "Mediakit / space too small" error), tried setting up my partitions, hit apply and... drum-roll. It worked that time!? Hope that helps someone else too.

  • Thanks, I was facing the same issue on mac os disk utility, and this resolve my problem smoothly. :) Happy Partitioning!
    – Code_Crash
    Mar 15 '20 at 5:47

I agree with Jens Erat for method 1.

For a detailed tutorial, read this topic: INCREASE DISK AND PARTITION SIZE IN OS X

Make sure that you understand what you are doing, take the time to write down the output of "gpt show dev/diskN" on a sheet of paper and double check it.

Be careful that if there is a hidden recovery partition after the "Macintosh HD" one for instance, increasing the size of this partition would overwrite the recovery partition.

I also suggest that you read the comments after the tutorial.

I did not test the lastest versions of GParted, so I cannot confirm if method 2 by Jens Erat works or not, but I assume so.

  • gparted 'fix' did not work for me - this manual GPT editing is what worked for me, though the gpt command for me did not work with the '/dev/disk0' method of reference, instead requiring just the device name: gpt show disk0 gpt destroy disk0 gpt create -f disk0 gpt add -b xxxx -s yyyy disk0 This is from the 10.6.7 install disk, so maybe it was different on the (more common?) 10.6.3 install disk.
    – reukiodo
    Dec 3 '16 at 1:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .