0

I have an iPhone 4S with 6.0.1 installed on it. I wanted to update it to 6.1.3 and not 7.x as iTunes suggests.

I downloaded 6.1.3 IPSW file for 4S from apple.com, shiftclicked update/restore in iTunes but I got infamous 3194 message. Same happened with 6.1.0 I tried to find some solution on the internet but of course 99.99999% websites were rambling about cydia hosts entries or whatever which, of course, I didn't have.

So I ran tcpdump to find out what iTunes is asking apple for and apparently some webserver (TSS is it called?) returns status=94 - not eligible. Before, I downloaded TinyUmbrella (as being one of the 'magic' solutions for 3194) which apparently had this TSS server inbuilt. I realized that if I run any post query in localhost/tss/ i'll get status=0 (success). So, I set gs.apple and gs-ns.apple entries to 127.0.0.1 and ran update, it finished faster than it started with error 11. Now iPhone shows iTunes logo and USB cable. I don't want to use "brand" iTunes restore because it'll "grant me" with ios 7 which I don't want. What can be done?

4
  • From my experience the saved SHSH blobs work only on iPhone 4 and lower and you can use iFaith to do that. On 4s and higher SHSH is useless.
    – unom
    Dec 25, 2013 at 11:41
  • I don't have any SHSH saved anyway (as it was upgrade not downgrade) so basically I used umbrella just to 'spoof' itunes so that it begins update.
    – Mike
    Dec 25, 2013 at 11:54
  • Well... that's your problem... you might have started the upgrade but it never finished as the phone needs confirmation from apple servers to finish the job... All you did is kind of start the upgrade but the phone never actually performed it. It just loaded it, prepared to do it, and then you didn't get the update signed off by apple servers. My take on the subject it that it still has the old iOS on it, it's just stuck on the connect to iTunes screen. You need redsn0w or something similar to kick it out of restore mode.
    – unom
    Dec 25, 2013 at 20:01
  • Then it will be your old 6.0.1 again. You'll never be able to update to 6.1.3 as Apple doesn't sign that version any more. Try to unbrick it. Then wait a little while as 7.1 will fix a lot of issues and people are already saying it improves performance a lot.
    – unom
    Dec 25, 2013 at 20:03

0

You must log in to answer this question.

Browse other questions tagged .