12

(on latest Mavericks)

While in VirtualBox (Ubuntu) fullscreen, on a Mac host, each time the mouse goes near the top, the Mac auto-hide menu bar appears - and I want to prevent that, or at least, since it's the annoying component, reduce the time it takes to that menu to disappear when the mouse goes down [currently it's ~1 seconds].

Ideally the time needed to trigger that menu should be higher than currently [instant] - eg like keeping the mouse on top for 1 whole second.

Illustration below shows the Ubuntu menu that has been overridden by the Mac menu when the mouse hits the top of the screen.

Ubuntu in VBox fullscreen - mouse hits the top...

There are already a few questions like this one that are either old or not answered.

Any progress in Maverics, near 2014?

3

So it seems someone found a working solution, at last.

First,

  • close your VMs
  • Quit VirtualBox

then as root (or sudo ...)

  • copy the file somewhere as backup, then edit (eg vi) /Applications/VirtualBox.app/Contents/Resources/VirtualBoxVM.app/Contents/Info.plist
  • and add the line shown in the middle

the line <key>LSUIElement</key> <string>1</string> to be inserted between LSCanProvideIMVideoDataSource and NSHighResolutionCapable

<key>LSCanProvideIMVideoDataSource</key>    <true/>
<key>LSUIElement</key> <string>1</string>
<key>NSHighResolutionCapable</key>          <true/>

save, then start VirtualBox again (I didn't have to log out/reboot).

The VM will not show anymore among the opened apps icons, but you can double click the VM in the VirtualBox to switch to it.

The whole post by Maestro is here.

  • do you happen to know if there's a similar hack for the dock? – Tin Man May 15 '18 at 22:55
  • @TinMan Not sure about the dock, but at least you can easily set it up to be left / right / down from the Mac interface, if that bothers you where it is now – Ring Ø May 16 '18 at 14:02
0

From the parallels forum, but could be a goer?

If you don't want the dock or menu to show up in Mac OS X full screen then you need to turn on active screen corners and then set the screen corners to not have any associated action.

(From the menu select "Virtual Machine" > "Configure...". Then select "Options" from the toolbar and then "Full Screen" from the list on the left side of the window. Check "Active Screen Corners" and select "-" for each screen corner.)

Parallels Forum - Answer #4

  • Unfortunately doesn't work in latest Mavericks / VirtualBox (this answer is for Parallels actually). – Ring Ø Aug 26 '14 at 9:23
  • The virtualisation software being used is Oracle VirtualBox, not Parallels Desktop. – Thomas Jones Oct 17 '14 at 6:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .