4

(I'm using wifi from a personal access point in my room, of which the security type is "WPA/WPA2 Personal" (it's what I see in network settings on my mac). Normally it just requires a password to login, no username is required.

My issue is that when I use my iPhone 5 (iOS 7.0.4) to connect to that wifi, it always asks for both username and password. I tried leaving the "username" field blank and fill in the "password" field only, but it says "Unable to connect to...".

This issue happens only on my iPhone and doesn't happen on any other devices such as Macbook, iMac or iPad.

  • If you go into Settings app > Wi-Fi and then tap the little i icon next to the currently used connection, is HTTP PROXY set to anything other than Off? – Lasse Dec 24 '13 at 19:37
  • it's already OFF. I tried resetting network settings but no luck... – Thiem Nguyen Dec 25 '13 at 4:03
1

The problem is that iOS is detecting your network as an Enterprise network that requires username and password. The work-around: Manually enter the network type into iOS. To do this with iOS 7.1: Settings / Wi-Fi / Choose a network, and select "Other". Put in the name (SSID) as it is advertised on the previous screen. Under Security, choose WPA2 or WPA (try both). Do not choose the "Enterprise" network. Enter the password. My experience is you have to try 3 or 4 times before it works; don't know why, maybe fat fingers.

-1

Change the router settings to only allow WPA. It is most likely set to Automatic which can choose WPA or WPA2.

You must log in to answer this question.

protected by Community Jun 1 '14 at 18:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .