I upgraded an old MacBook Pro to Mavericks, and I am now trying to download Xcode.

In App Store I searched for "xcode", found it, clicked "Install".

It is now saying "INSTALLING", but nothing happens, CPU at 0%.
If I let the computer unattended, it falls asleep (disk stops).
While waiting I tried to install MacPorts, but it says Waiting for other installations to complete..., so the installation is still going on somehow.

What should I do? Restarting App Store and does not fix the problem.

I rebooted and re-clicked INSTALL, and still the same problem.

It is a bit similar to this question but I have no /Library/Preferences/com.apple.SoftwareUpdate* file to delete.

3 Answers 3


Maybe this thread on Apple Support Communities is what you're looking for.

It sounds like it is, indeed, a cache problem. From the thread above, it'd seem you'd need to find the cache in the /private directory. I'll include specific instructions, inspired by the thread:

  1. Open Terminal (/Applications/Utilities/Terminal.app)
  2. Type in this command: sudo find /private/var -iname "com.apple.appstore" and press Enter
  3. For each of of the found directories run rm -r <dir path>/* (For the brave: sudo find /private/var -iname "com.apple.appstore" | xargs sudo rm -r)
  • I did this but also had to restart my machine afterwards.
    – maryisdead
    Nov 17, 2015 at 9:02

Go to the App Store app. Click purchases. Click Pause on the app. It should pause.

Now search for the app again and it should say "Install". If you go to the purchases tap you should see that it restarted.


I have encountered this issue a couple of times, lastly while trying to install Microsoft Word from the Apple Mac Store. The following steps solved the problem for me:

  1. Close the Apple Mac Store COMPLETELY.
  2. Wipe the contents of the App Store cache folders. To do so, enter the following in your command line:
sudo rm -R $TMPDIR../C/com.apple.appstore/*  
sudo rm -R ~/Library/Caches/com.apple.appstore/*  
sudo rm -R /Library/Updates/*  
  1. Kill all the processes shown in the Activity Monitor being listed when searching for ‘store’:

App Store process deletion

  1. Delete you App Store Preferences and Cookies:
sudo rm -R ~/Library/Preferences/com.apple.appstore.plist  
sudo rm -R ~/Library/Preferences/com.apple.storeagent.plist  
sudo rm -R ~/Library/Cookies/com.apple.appstore.binarycookies  

And that's it, just start your App Store normally, and retry to install your app.

P.D.: A reboot may be needed
P.D.: Don't freak out if the RMs say these files/folders do NOT exist and therefore they can't be deleted, you just are where you wanted to be already
P.D.: I know, I know, some of these commands do not need SUDO rights, but it doesn't hurt to using them either

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .