1

Until recently, on OS X 10.8, I was using Alfred (which in turn uses Spotlight) to search files and directories on an encfs-mounted partition (which is mounted off a folder in my Dropbox directory).

I used to use the command sudo mdutil -i on ~/Dropbox-encfs to enable indexing for that partition once it had been mounted (typically, I remounted every time I rebooted).

However, since upgrading to OS X 10.9, entering the same command returns the error Error: unknown indexing state. Indexing and searching on my main root partition continues to work:

~$ sudo mdutil -a -s
/:
    Indexing enabled.
/Users/myuserdirectory/Dropbox-encfs:
    Error: unknown indexing state.

Has something changed in OS X 10.9 that might cause this? How would I go about debugging or fixing this problem?

I'm using encfs version 1.7.4p1. I've already tried turning on and off the indexing (-i on, -i off), and using the -E flag to mdutil to erase the store.

I mount the encfs partition using the following command:

sudo encfs --public -ovolname=Dropbox-encfs ~/Dropbox/.encfs-crypted ~/Dropbox-encfs

Aside from the indexing problem, the mounted encfs partition otherwise seems to work fine.

I should add that I am also seeing warnings of this form in /var/log/system.log:

Dec 23 14:51:20 montpelier.local mds[57]: (Warning) Volume:
vsd:0x7ffe0c826c00 Open failed.  failureCount:7
  • 1
    I'm on 10.9.1 and can get the status to show "Indexing enabled" for the encfs volume when appending the option -o local. Nevertheless, files from inside the volume still do not appear for me in searched for some reason. – GJ. Dec 26 '13 at 16:47
  • @GJ, perfect, that worked for me - and I do get the search results. Thanks. Not sure why it doesn't work for you - perhaps indexing hasn't yet finished? I monitored it with the Spotlight icon in the top-right. If you turn this into an answer, I'll mark it correct. – Andrew Ferrier Dec 26 '13 at 21:44
  • Let me be more precise: I can search inside the encrypted volume when initiating the search in a Finder window that is currently viewing the volume, and switching the search scope at the top of the results from "This Mac" to just "Dropbox-encfs", which means the Spotlight index is probably fine. My problem is that I can't get combined results across both the entire regular disk and the encrypted volume. Any ideas for that? – GJ. Dec 27 '13 at 7:34
  • @GJ, hmm, well I don't do my searches that way - I use Alfred to initiate my search, as I mentioned in my Q. I just tried it in Finder, and the results do seem to be separated. I think that may be by design, though. – Andrew Ferrier Dec 27 '13 at 12:04
  • Andrew, do you also get the dropbox to get stuck on the "syncing" mode due to the spotlight folder having permission problems? Or did you manage to work around that? – GJ. Mar 28 '14 at 18:15
3

Appending the option -o local to the mount (i.e. encfs) command seems to work...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .