On some wireless networks that others can seem to access just fine, my MacBook Pro won't connect, I get an error like this in the Network pref panel:

AirPort has the self-assigned IP address 
and will not be able to connect to the Internet.

This occasionally happens with unsecured networks, and also with secured networks where I know the password is right, and the password appears to be accepted.


Can also depend on the router. Some routers allow you to change the 'index' or 'key' that is in use. IE - you can define say 4 different keys or passwords that the wireless network can use, then you tell it which one you want to be in use right now.

My experience has been that Macs will always try to connect using index or key 0, never any other key. The connector (MB or MBP) has to be using the same index or key number for the wireless handshake process to work properly.

I've had situations, therefore, where PC's were connecting just fine to a well-setup network and there was no reason the Mac shouldn't - and an hour or so later I figured out that that's what it had been the whole time.

Frustrating to say the least. May be fixed now, I think last time I ran into it was an early 10.6.

  • is there any way to set the index, either on the Mac, or on the router so it works? – user5086 Apr 8 '11 at 11:52
  • You will have to find the option in the router settings. Once you do find it, change it to 0 or 1, whichever is lowest, and try again. – Harv Apr 8 '11 at 17:24
  • this worked, thanks. logged into router, the "channel" was set to 6. Changed it to 1, which was the lowest option, and connected fine. – user5086 Apr 19 '11 at 13:31
  • Aah, be aware. That is not related to what I was talking about. The channel is analogous to the channel on a TV. Depending on surrounding devices, you will get better or worse reception by virtue of interference. Still, changing the channel from the default, 6, is a good move regardless. – Harv Apr 20 '11 at 7:43
  • so where do you find the option in the "router" or any other device settings. for example I have an iphone tethered with tetherme and when I try to connect via wifi, it gets me the "WIFI has a self assigned IP of and will not be able to connect" on the other hand MiFI does not have this problem – user6877 Jun 1 '11 at 4:24

You must log in to answer this question.